Adjustments to the E-Newsletter Sign Up Form

The standard E-Newsletter signup form (via widget or shortcode) shows different fields in multisite whether the viewer is signed in or not.

A non-member sees a field for their name and email address, and optional groups to join. A signed-in member just sees a "join newsletter" button (also with options to join a specific group).

I do not want it to change based on signed in status. I would like for it to ALWAYS show the actual fields. My members, after a digital lifetime of seeing mail chimp forms, are thoroughly confused by the lack of fields on the registration forms. It is only causing a tremendous string of questions and assurances, followed, ultimately, by a lack of use of the plugin.

Please change this. Or, at least, give site holders the option of changing this. I know it is a feature with the best of intentions, and is meant to streamline the registration process -- but it isn't. Quite the opposite, actually.

I've overcome this in some cases with a custom HTML form -- but that has it's limits and there is a lock of trust from users when they realize the plugin has to be hacked to be effective.

Please change the sign up form/widget/shortcode for eNewsletter in multisite. It's not working.

Thanks.

  • Vinod Dalvi

    Hi @jetmac,

    I hope you are well today and thanks for posting on the forum.

    I do not want it to change based on signed in status. I would like for it to ALWAYS show the actual fields.

    There is already a feature request created for this feature and this feature may be added in future version of plugin based on the number of feature requests we get for it but We don't publish ETAs to prevent disappointment if a deadline is missed(which in plugin development quite a frequent occurrence!).

    Currently you can achieve this by using the solution posted in the following reply.

    https://premium.wpmudev.org/forums/topic/can-the-suscribe-form-always-show-the-email-field#post-823786

    Please change the sign up form/widget/shortcode for eNewsletter in multisite. It's not working.

    I have tested it on my test multisite using latest version of e-Newsletter plugin and its widget and found it's working fine.

    Could you please tell me specificaly what's not working on your site?

    Also i can see you are using older version of e-Newsletter plugin so please try updating it to the latest version.

    Best Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.