admin-ajax.php Pushing My Speed Test Out

Hello,

I usually use Pingdom's Speed test and I am currently just helping a friend out with his site but it seems when I run a pingdom speed test the file admin-ajax.php appears TWICE and the second time it appears its 0kb which seems to add another second on to the page speed.

Once is the best way to track down these issues?

Also, he is using DIVI Editor and it seems that the fonts for 'gstatic' aren't being loaded over HTTPS and I don't know how to dig in to update it so I don't get those errors in inspect.

Thanks,
Aaron

  • James Morris

    Hello MoneyBearMagic,

    I hope you are well today.

    Regarding the first issue, this is most likely due to a poorly coded plugin or theme. You're best bet is to go through a systematic plugin/theme test to determine which is adding the code to your site's header. Our plugin/theme conflict test is the basic process you would need to use to determine what is adding this code to your site.

    You can learn more about this process here -> https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    As far as the issue with Divi goes, I would need to take a closer look to determine what is going on there. Generally speaking, if the Google Fonts are not being loaded over HTTPS, then it's in a configuration option somewhere, or hard coded. If you would like, you could enable Support Staff Login and I could take a look to track down the source of the problem.

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • James Morris

    Hello MoneyBearMagic,

    I apologize for the delay in replying.

    Taking a look at your site, it appears that the incorrect URL for the Google Fonts was being called from Hummingbird cache. I rechecked your files in Hummingbird and the font URLs are correct in the backend of your site, but they still are not on the frontend. This is because you are using Cloudflare. Cloudflare has cached the URLs for the fonts is and displaying them to the end user.

    Could you please clear your cache on Cloudflare and recheck your page?

    Best regards,

    James Morris

  • MoneyBearMagic

    Hi James,

    I did this and it made no difference, I have tried removing the CloudFlare name servers and it still had issues, then I turned off Humming Bird and still have issues.

    The site currently hits like 16 seconds in terms of Speed Test and now after uploading youtube videos I am getting some weird cast-sender.js errors when performing a speed test.

    Really would like to optimise the site in terms of speed, are you able to help out by logging on to the site or give me a step by step guide etc?

    Thanks,
    MBM

  • James Morris

    Hello MoneyBearMagic,

    I've logged into your site and made some minor changes. I re-enabled minification in Hummingbird, and excluded all font references. You're mixed content issues are no longer a problem.

    See screenshot:

    I also went through your Hummingbird settings to make sure they are good and everything looks fine.

    I've enabled Convert PNG to JPEG in Smush Pro and smushed the 9 images that needed Smushed.

    Checking your server configuration, I see a few things that could be improved upon:
    * PHP Version 5.4.45 is very old. The oldest, stable version that you should run is 5.6.x. PHP Version 7 is the latest stable version and has significant performance enhancements over the 5.x branch. You may want to have your host upgrade your PHP version to at least 5.6.x.
    * Your max_execution_time is set to 45. This is pretty conservative. I'd recommend bumping this up to at least 90 seconds. I usually run mine at 180 seconds.
    * display_errors and log_errors are enabled in PHP. Unless you are debugging, it's better to leave these disabled.
    * In your WordPress config, WP_MEMORY_LIMIT is set to 40MB, but you can run up to 256MB on your server. Adding the following line to your wp-config.php could improve performance a little bit.

    // Increase WP Memory Limit
    define('WP_MEMORY_LIMIT', '256M');

    I see you are running some pretty heavy plugins on your site. JetPack, for example, makes numerous calls to externally hosted services. These external calls cannot be minimized or cached like locally hosted resources. While JetPack certainly has it's place, if you are concerned about improving your site's performance significantly, you may want to find plugins that don't use so many externally hosted resources.

    A recent blog post here goes into the difficulties of achieving a perfect score on Google PageSpeed. https://premium.wpmudev.org/blog/100-score-google-pagespeed-insights-not-happening/

    That being said, you can use tools like https://tools.pingdom.com/ and https://premium.wpmudev.org/wp-checkup/ to get a clearer picture of what is causing your site to be slow. Much of the problem is external resources and images that are not optimized.

    I hope this clarifies a bit.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.