Admin Bar disappears on Mapped Domains

On sites that have a mapped domain using the Domain Mapping plugin, the Admin bar has disappeared as well as the "Edit Page" option in the page content. It works fine on sites within the network that do not have the domain mapped.

Domain Mapping settings:

Allow site admins to set multiple mapped domains: UNCHECKED

You can allow your members to access the administration area of your site through the domain they enter, you can also restrict it to the Mapped domain or the original domain (your website url): ORIGINAL DOMAIN

How should your members access the login page of their website, this can be through the domain they enter, or restrict it to either the Mapped domain or the original domain (your website url): ORIGINAL DOMAIN

Would you like for your members to be logged into all sites within your network regardless of domain name: NO

Would you like to verify domain's DNS settings before they will be mapped by your members: YES

Would you like to check domain health and propagation before mapping: NO

Would you like to force https in login and admin pages: YES

Would you like to force http/https in front-end pages: NO

Disallow sub-domains of the original domain to be used as mapped (primary) domain for sub-sites : UNCHECKED

Allow site admins to set map-excluded pages: CHECKED
Allow site admins to set map-excluded urls: CHECKED

Allow site admins to set https-forced pages: CHECKED
Allow site admins to set https-forced urls: CHECKED

  • Patrick

    Hi there @Matthew

    I hope you're well today!

    If you have set Login Mapping to original domain and Cross-domain autologin to No, when a logged-in user visits the frontend of the site, the adminbar will not display as they are simply not logged-in. :slight_smile:

    They would need to also log into the site at the mapped URL to be able to view the adminbar.

    To prevent that, you could simply set Login Mapping to Domain entered by the user.

    As for the Edit Page screen, I haven't been able to replicate that. There may be some other plugin/script conflicting here somehow. Please implement basic troubleshooting protocol as illustrated in the diagram at the bottom of this page to locate any such conflicts if they exist:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    As seen in the below screenshot, the site mapped.pcwriter.net is mapped to pcwriter.info and the Edit Page screen shows fine, as well as the adminbar both frontend and back.

  • Sonya

    Well that is sort of a problem. I have several sites that are mapped and several sites that aren't. It is very inconvenient to have to continuously having to type in wp-admin back in the browser whenever I need to get into the back end whenever I need to make an edit instead of choosing the Edit Page option in the admin bar or in the page body (page body is based on theme capability), but because it does not recognize me as logged into the mapped domain, I don't get that. I'm not sure why it can log you into both or recognize you are logged into the original and feed the admin bar to you automatically.

    My login and admin pages must be https: but we don't want to have to buy a SSL cert for every single mapped domain.

  • Sajid

    Hi @Matthew

    Hope you are doing good today :slight_smile:

    To login to entire network inlucding the domains you mapped. You have to enable

    Cross-domain autologin

    as stated by @Patrick in his reply. I flagged Patrick on this thread as well for their feedback also.

    Have you tried to login by disabling this option Force http/https (Only for original domain) ?

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.