Admin cannot see the menu for Membership plugin

Problem: Admin can activate/deactivate the Membership plugin, but cannot see it in the dashboard menu.
The only way to see the Membership plugin is to log in as a super-admin.
Question: how do I make it possible for the Admin to see and access the Membership options. When I type in the address directly ( get the message "You do not have sufficient permissions to access this page."

  • Alex

    Hi Ari,

    I don't think that's the problem. The demo site that I am testing is set to be at the Presenter level. I am more then happy to network-activate this plugin, if this would help individual Admins to see it on the menu. I want all individual site admins to be able to set the membership levels.

    However, no matter what I try, this plugin remains visible only to super-admins.

    Thank you for looking into it,

  • Alex

    In addition to my previous message: I've tried network-activating the Membership plugin, but it does not show in the dashboard menu for admins, only for super-admins.

    After that I've added these 2 lines to wp-config.php:define( 'MEMBERSHIP_SETACTIVATORAS_ADMIN', 'no');
    define( 'MEMBERSHIP_GLOBAL_TABLES', false);
    This did not help.

    Then I network-deactivated the plugin and activated it as an admin. As an admin I can activate it or deactivate it, but I cannot see it in the dashboard menu. Whether I have MEMBERSHIP_SETACTIVATORAS_ADMIN set to yes or no makes no difference.

    Please advise.

    Thank you,

  • Michelle Shull

    Hi, Alex!

    I've got a screenshot attached, I looked at a subsite and I was able to see the Membership tab in the sidebar. This is the Membership Admin tab that's mentioned in our documentation. Your screenshot is of the Membership Options, and those are the standard tabs.

    All your settings look correct to me, can you provide me a little more detail about where you're seeing the issues?

  • Alex

    Hi Michelle,

    The problem is no longer there, but I know what caused it and how to reproduce it. I hope that other users in my situation will find this information useful.

    When I disabled WP Super Cache plugin, everything started working beautifully.

    While WP Super Cache was running, users logged in as administrators were unable to see the Membership items on the dashboard menu after activating the Membership plugin.

    If you decide to use WP Super Cache, you MUST CHECK "Don’t cache pages for known users" in the Advanced tab. Even with this option on, it is still a good idea to completely clear the cache every now and then.

    I think that we can safely mark this topic as Resolved :slight_smile:

    Thank you,

  • Alex

    No, no, no, no, nooooooooooo! Just when I thought I have this one resolved, the problem reappeared.

    Michelle, did you log in as an admin or as a super-admin when you managed to see Membership in the desktop menu?

    It works for super-admins, it does not work for admins, this is the problem I am trying to fix.

    Here's the video I made that hopefully illustrates the problem that I am having:

    The Membership plugin simply refuses to appear on the dashboard menu for administrators no matter what. I have now deactivated all plugins. Not a single one is active. When I activate the Membership plugin, it's the only one that is active, but it still won't appear in the menu when I am logged in as the Administrator. If I log in as a super-admin, it's there.

    Please help!

    Thank you,

  • Tyler Postle

    Hey Alex,

    Hope you're doing well today and thanks for the screencast! A visual aid always helps :slight_smile:

    When you did that were all the network activated plugins deactivated as well? Even though those don't show on the subsites plugins list they are still considered 'activated' on those sites.

    Also, from your 'admin' account would you mind trying to visit the Membership link manually 'domain.comwp-admin/admin.php?page=membership'

    This will determine whether something is simply hiding the menu or if it is actually affecting the capability of the user role.

    Look forward to hearing back :slight_smile:

    All the best,

    Also, another thought I just had. Deactivating wp-super-cache doesn't truly deactivate all of it, as it adds code to your .htaccess file as well. You will also want to find the advanced-cache.php file in your /wp-content and delete that.(it's generated by caching plugins).

    Let us know if you need any assistance with any of this.

  • Alex

    Hi Tyler,

    Yes, for my test all the plugins were deactivated, including the previously network-activated ones. When I activated Membership, it was literally the only plugin running.

    I have since reactivated the plugins because this does not seem to be the problem.

    Sorry, I should have reported earlier, the "?page=membership" test was one of the first I've done, and the Membership menu is definitely not just hidden, the admin does not have the capability to access it. Going to produces the following error: "You do not have sufficient permissions to access this page."

    Something somewhere is restricting the capability of the admin.

    What I find strange is that while the admin who activated the Membership plugin does not have the permission to access the Membership menu, the same admin can elevate another user to the admin status, and that other user can then see Membership in the menu and change the settings.

    Thank you for looking into it,

  • Tyler Postle

    Hey Alex,

    Hope you're doing well today and apologies for the slow reply!

    If your membership plugin is network activated then that could be the issue because then only the Super Admin who activated the account will have full access to all the membership options. If you activate on a site by site basis then each site admin will have full Membership capabilities and won't be restricted by it.

    This post here will provide some more possible solutions :slight_smile:

    I notice your account is inactive; however, I'd still like to help you get this resolved if it isn't already! You can contact me directly through our contact form:

    Select "I have a different question" for your topic and use subject line: "Attn: Tyler Postle"

    This will ensure it gets to me if needed :slight_smile:

    Have a great weekend Alex!


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.