Admin Footer Text Issue – Please Help!

Hi,

I have a strange issue. I get an error message whenever I try to save the Super Admin Options page. In get:

Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'admin_footer_text_site_admin_options_process' not found or invalid function name in /home/********/public_html/wp-includes/plugin.php on line 395

Warning: Cannot modify header information - headers already sent by (output started at /home/********/public_html/wp-includes/plugin.php:395) in /home/sarahssu/public_html/wp-includes/pluggable.php on line 890

I am running 3.0.4, with the latest version of Admin Footer Text installed as instructed (in plugins, network activated). Admin Footer Text does show up as its own separate menu under Super Admin.

Any help will be appreciated.

Thanks,

Mark

  • SooBahkDo
    • Syntax Hero

    same here:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘admin_footer_text_site_admin_options_process’ was given in /home/content/44/7050844/html/wp-includes/plugin.php on line 395

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/44/7050844/html/wp-includes/plugin.php:395) in /home/content/44/7050844/html/wp-includes/pluggable.php on line 890

    I did enter some text in the Admin Footer text settings box to assure this was not related to a null value, but still no joy.

    Phil D

  • drmike
    • DEV MAN’s Mascot

    latest version of Admin Footer Text

    I;m showing that the 1.0.6 version is for 3.1+.

    This may be another case of we have a newer version out too early.

    Can you confirm what version of the plugin you’re using is please?

    edit: Also make sure you don;t have the rebranding pack in there. I don;t think you do since the error messages are different. Just wanted to mention that though.

  • wpcdn
    • Syntax Hero

    Hi Mike,

    Yep, I’m running 1.0.6. I didn’t see that it was only for 3.1 though. The plugin page lists 3.0.4, and the changelog says:

    – 3.1+ compatibility update.

    I didn’t realize theis meant only 3.1, I thought it meant that compatibility for 3.1 and above was added. Oops.

    I see the 3.1+ thing in a few changelogs. Should I revert all of those? We’ve decided to stay on 3.0.x for a while.

    Thanks,

    Mark

  • wpcdn
    • Syntax Hero

    The previous version that lives in mu-plugins still works without error on WP 3.0.4, so I just reinstalled it pending resolution of this issue.

    I am happy to do this too, so no rush on resolving this. The old version is a viable solution.

    Followup question though: Should I go back to previous versions on other plugins too? I’m still not sure whether the 3.1+ means that I shouldn’t use a plugin with 3.0.4, or if it’s generally okay.

    Thanks,

    Mark

  • wpcdn
    • Syntax Hero

    Followup question though: Should I go back to previous versions on other plugins too? I’m still not sure whether the 3.1+ means that I shouldn’t use a plugin with 3.0.4, or if it’s generally okay.

    Just curious as to the answer on this.

    Thanks.

  • Mason
    • DEV MAN’s Sidekick

    Hiya wpcdn,

    Other plugins should be fine. We’ve tried to make them 3.1 compatible without breaking any current compatibility. Of course, on a live production site I always say ‘if it ain’t broke…’

    In this case, I don’t think the issue was related to the upgrade for 3.1 compatibility, but a small glitch in the code.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.