Admin notifications not sending - Appointments +

Hey Guys,

Sinced Ive moved the site to a new faster server, my admin notification emails are not coming through. Which is weird as the confirmation emails are being sent, so its nothing to do with the server. I have recently updated the plugin hoping that It would solve it, but they still are not coming through.

Also i've checked the notification settings in the backend and this is what it is currently set too.

Send Confirmation email YES Whether to send an email after confirmation of the appointment. Note: Admin and service provider will also get a copy as separate emails.

  • Nithin

    Hi Rudie,

    Hope you are doing good today. :slight_smile:

    I checked the this in my system, and it seems like the notifications aren't working, and I'm able to replicate this issue. I'm marking this as a bug, and I'm bringing this in developers attention, so that he could give a closer. Will keep you posted, once we have a stable patch ready regarding this bug.

    Thank you for reporting, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Rudie,

    Hope you are doing good today. :slight_smile:

    I just got an update regarding this from the developer, and the issue in my system was related with Payments required option being enabled, under Appointments > Settings > Payments, and the email notifications will not send if it requires a payment.

    I checked your system, and I could see you didn't have payment enabled, so I suppose you meant the service providers aren't receiving any notifications, for that, you'll have to enable Allow service provider confirm own appointments option, under Appointments > Settings > Accessibility.

    I just enabled that option in your system, could you please test, and see whether it works fine now. I hope this helps. Please do let us know if you still have any issues related to this, so that we could give a closer look, if needed. Have a nice day. :slight_smile:

    Kind regards,
    Nithin

  • Nithin

    Hi Rudie,

    I do understand you, and I did mention that payment weren't enabled in your system, however I could see we have a new plugin update to version 2.0.2. The latest version comes with many fixes, could you please update the plugin, and we would like to test this issue in your latest version, please check whether updating the plugin works fine.

    It seems like it's a live site, if you still have issues after updating, is it okay if I could test your system by creating new appointments, and see how that goes?

    Please do let us know how that goes, so that we could give a closer look, if needed. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello Rudie,

    I tested on my installation and I could not replicate this issue - I tried to copy settings you have on your site, so settings should be correct.
    What is strange that on both sites yours and mine logs are not showing confirmation message sent to service provider - however I did receive it. Because I understand that running plugin conflict is not an option I would like to check debug log. To enable debug mode, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see content of the debug.log file - so please upload it to service like dropbox and paste link here.

    kind regards,
    Kasia

  • Rudie

    Hey Kasia,

    I have updated the plugin today, and the notification are being sent to the people who are booking, but the service provider is still not getting the email confirmation... I have followed the above steps and uploaded the debug.log file to my drop box. Please see attached link.

    https://www.dropbox.com/s/z5aoumd2wgyzw1l/debug.log?dl=0

    I hope you can help with this as its starting to effect our business.

    Regards

    Rudie chiu

  • Rupok

    Hi Rudie chiu,

    Thanks for providing the debug log. I could not find anything specific there. But I want to do some extensive test on your site to find out the reason. If I can't find out, I'll ping one of our SLS (Second Level Support) guy to investigate this.

    Now, to investigate further, I'll need your WP and FTP credentials. Can you send me a message with FTP and WP access credentials through our secure contact form here: https://premium.wpmudev.org/contact/#i-have-a-different-question ?

    Subject: "Attn: Rupok"
    - WordPress admin Username
    - WordPress admin Password
    - Login URL
    - FTP Username
    - FTP Password
    - FTP Host
    - Link back to this thread for reference
    - Any other relevant URLs

    The subject line ensure that it gets assigned to me.

    Please confirm when you are done sending. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Rudie,

    Thanks for sending the credentials. They are working.

    I've checked your site configuration and they seem to be configured fine.

    So to regenerate this issue on your site, I created a new user, made that user as a service provider, and created a test appointment for that server provider. When I checked my email inbox for that service provider account, I found the confirmation email there. Please check the attached screenshot for reference.

    So emails are going fine for your service providers too from your site. As you said your Provider user email is not getting emails, can you please check your spam folder?

    Please let us know what you find. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.