Admin permissions access error

Believe we have found a bug.

Under Membership > All Members
The landing page pulls fine. The path displayed is /admin.php?page=membershipmembers

Clicking page 2 displays "You do not have sufficient permissions to access this page." The path is /admin.php?page=members&userspage=2

Changing this link manually to /admin.php?page=membershipmembers&userspage=2 pulls correctly.

Any thoughts on this error appreciated.

  • aecnu
    • WP Unicorn

    Greetings honustudios,

    Trying to confirm this on my development server and cannot get enough members to get to page 2 and ran out of emails trying to do so.

    I will go ahead and ping the lead developer of this Membership plugin about this probability.

    Thank you for not only including the code causing the error but the fix as well, it is greatly appreciated, some rep points sent your way.

    Cheers, Joe

    Dev Note: Under Membership > All Members
    The landing page pulls fine. The path displayed is /admin.php?page=membershipmembers

    Clicking page 2 displays "You do not have sufficient permissions to access this page." The path is /admin.php?page=members&userspage=2

    Changing this link manually to /admin.php?page=membershipmembers&userspage=2 pulls correctly.

  • aecnu
    • WP Unicorn

    Greetings honustudios and jperez48,

    Though Barry is mum on when the next update will roll out which is typical WPMU Dev protocol, I have discovered that it is his normal mo to pack a few fixes or more into an update rather then piece meal.

    I am sure looking forward to the next round of updates to our new V 3 of Membership plugin as I am sure you folks are too and it is certain that it is on its way ...

    Cheers, Joe

  • amichel
    • Flash Drive

    I am also experiencing the same issue.

    Unfortunately, I cannot simply tell my non-technical clients to start fudging with the URLs in the new website they paid me for. No. That would be unprofessional and it would increase their workflow. Not the kind of client support I like to offer.

    Instead, I took it upon myself to fix this bug PRO BONO - hence LOOSING money - AGAIN - trying to make Membership work. My clients expect me to support the website I developed for them. But why should I expect support from the plugin that I paid for? That would make no sens, right? Instead I get the runaround with NO TIMELINE provided from the developers other than 'soon'.

    Not good enough.

    Enough ranting. Here's the fix

    Edit the following file: membership/membershipincludes/classes/class.membersearch.php

    Scroll to line 47. Change:
    'base' => 'admin.php?page=members&%_%',
    to:
    'base' => 'admin.php?page=membershipmembers&%_%',

    That, fellow Membership users, is how you actually solve a problem. Not with 'a fix is coming soon' PR.

    BTW, that took me about 15 minutes to figure out, and I'm only a hack developer.

    Hope this can save others some head scratching.

  • Barry
    • DEV MAN’s Mascot

    There is an interim bug fix release with this fix in it on the main membership 3.0 thread at the top of the forum. Scroll down towards the bottom of that thread and you'll see a post by me with the link to download it. I can't post it on here at the moment as I'm not on my computer.

  • aecnu
    • WP Unicorn

    Greetings honustudios,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings honustudios,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.