Admin Toolbar not showing to non-admin members after activating Membership Pro 2

The admin toolbar is not showing to non-admin members.

  • Ash

    Hello Marcos

    Please go to Dashboard > Membership 2 > Settings > General and disable "Hide admin toolbar". Please check the screenshot:

    Furthermore, you can also try the following code:

    function hide_admin_bar( $show ) {
    if ( current_user_can( 'author' ) ) {
    return true;
    }
    return false;
    }
    add_filter( 'show_admin_bar', 'hide_admin_bar', 9999 );

    You can use this code in your child theme's functions.php if the theme is not changed. Otherwise mu-plugin is the best option. To create a mu-plugin, go to wp-content/mu-plugins folder. If there is no mu-plugins folder then, create one. Now, inside the mu-plugins folder create file with name anything.php (make sure file extension is .php). Now start with a <?php tag and then put the above code.

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,
    Ash

  • Nithin

    Hi Marcos,

    Hope you are doing good today. :slight_smile:

    In general, once the above mentioned option "Hide the admin toolbar for non administrator users." is disabled, it should have listed the WP admin bar with options showing in there.

    There isn't any other specific setting in Membership 2 Pro that could be causing this other than the mentioned option. I don't see support access to your site enabled at the moment, so it's tough to say what else could be causing this without giving a closer look.

    Since I don't see you mention about a plugin conflict test, could you just disable all the plugins in your system, except WPMU DEV Dashboard, and Membership 2 Pro plugin, and then see whether you still get the same issue, or not?

    This would give a better idea, where the issue is located. If you still have issues even after running a conflict test as above, then please enable support access, so that we could have a better idea.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Looking forward to your response, so that we could give a closer look, if needed. Have a nice day ahead. :slight_smile:

    Regards,
    Nithin

  • Nithin

    Hi Marcos,

    Sorry to hear that the issue hasn't been resolved, plugin conflict test is recommend when the site doesn't behave, or work as it's supposed with the plugins.

    This is the basic troubleshooting method when it comes to resolving conflicts similar to the one noticed in the current ticket.

    I do understand, if you don't want to look further at the issue, however if change your mind, and still think this is something you want use to troubleshoot, then please send us your websites credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.