Administration Priveleges

Ok guys I've setup my site to work using defilms.com.au it's hosted with wpmudev. I've masked the login area via defender as far as I can tell. When I go to admin section it looks like a subscriber priveledge as I don't have administrative privileges no access to pages post or any features in the left side pane.

Also is there a way of now accessing cPanel?

  • Nithin
    • Support Wizard

    Hi David Edwards,

    That's odd, masking a login URL via Defender shouldn't cause such a behaviour, nor Defender has such an inbuilt feature out of the box. This could be more related to some other plugins enabled in your system.

    I'm afraid, our Hosting is custom Managed Hosting, and at the moment we don't offer cPanel. You can create SFTP user, or SSH users via the Accounts tab for your site, which should allow you to access your server:
    https://premium.wpmudev.org/hub/hosting

    You could disable all the plugins by going to /wp-content/ folder via SFTP, and renaming the /wp-content/plugins/ folder to /wp-content/plugins-off.

    If you are looking to disable plugins individually, you could do that by renaming the plugin folder name, under /wp-content/plugins/plugin-folder-name/ to wp-content/plugins/plugin-folder-name-off/

    Once the issue is fixed, please make sure to revert he changes made with renaming the folder names.

    Please do let us know if you are still looking to troubleshoot the issue further, so that we could give a closer look, if needed.

    Regards,
    Nithin

  • David Edwards
    • Design Lord, Child of Thor

    Hi Nithin, Thank you for your help, I have disabled Defender in the hub. My main problem is that when I do log in, I don't have administrative privileges. I've provided a screenshot of my admin area. this seems to have happened after I attached my URL to the hosting.

  • Kris
    • Support

    Hi David Edwards

    I was able to switch to your account via our panel. I also create temporary SFTP account to create super admin account on your site via mu-plugin. After that I was able to log in to site as admin and I was able to see every edit mode for posts and pages (I also set up temporary masking login area and I was not able to replicate this issue).

    Of course I reverse my steps: deactivation of masking login area, delete user and SFTP account.

    I also log in to your data base and I check wp_capabilities for you admin account and it have correct set up:
    a:1:{s:13:"administrator";b:1;}

    I will need your current login and password you use for this site to take a closer look on this. Please don't share any sensitive information (i.e credentials) in the Support Forum, it has public visibility and everyone will have access to it. Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is "I have a different question" and:
    - Mark to my attention: ATTN: Krzysztof Tomczyk
    - Site details (login url / username / password)
    - Link back to this thread

    Please confirm here in thread that you have sent that message.

    Kind Regards,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.