Advanced Filter: Headers already sent error with Marketpress and Pro3/FullWidth theme

I'm working on a development site.

Using:
Marketpress ecommerce
Pro3 theme with Fullwidth child

Was using the jQuery filter without issue. Tried to use the 'advanced filter' feature and then got this error thrown at the top of the page (see attached image):

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/81/4368081/html/4spottemplates/vanatkins/wp-content/themes/fullwidth/header.php:2) in /home/content/81/4368081/html/4spottemplates/vanatkins/wp-content/plugins/marketpress/marketpress.php on line 989

Any clue on what is causing this and/or how I can fix it?

Thanks in advance.
Jeff

  • Patrick
    • Support Monkey

    Hi there @jeff arnold

    I hope you are well today!

    I get that also with the Pro3 theme and MarketPress 2.9.0.5.

    Line 989 in MarketPress is this:
    if (session_id() == "")

    I tried changing it to this (as the same function appears to be triggered in Pro3):
    if (!function_exists('session_start') && session_id() == "")

    But that threw an "Oops, missed a step..." error during checkout.

    I'll notify the plugin developer of this issue to see what insight he can provide.

    Also, perhaps the developer of the Pro3 theme, @nathanon, can help out here.

  • mcmasterp
    • The Incredible Code Injector

    I am getting this:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/mcmaster/public_html/mcmasterclaims.com/wp-admin/includes/template.php:1698) in /home/mcmaster/public_html/mcmasterclaims.com/wp-content/plugins/marketpress/marketpress.php on line 989

    on a users profile page in the backend.

  • jeff arnold
    • The Incredible Code Injector

    If I had switched the theme and then had the issue occur, then I could certainly see that as the main culprit, but what has me perplexed is that I used the same theme, but just switched from the jQuery to the 'advanced' search feature and that is when this error kicked out.

    ???

    Jeff

  • jeff arnold
    • The Incredible Code Injector

    I have gotten rid of it, too.

    Here is what I know that I did ... not sure what I may have done inadvertently. :slight_smile:

    Updated Markepress to 2.9.0.8. (still had error)

    Switched to the FlexMarket theme (still had error)
    Switched to the Pro 3 theme (still had error)
    Switched to the FullWidth theme (still had error)

    Deactivated:
    Dynamic Grid
    a variety of other plugins
    Marketpress

    Still had error

    Reactivated Marketpress (still had error)

    Re-uploaded FullWidth theme via FTP (still had error)
    Re-uploaded Marketpress via FTP - error gone

    Somewhere, something must have glitched with one of the core files.

    I'm going to leave this open for a little while and not mark as resolved yet, as the last time the error just popped up out of nowhere. If all goes well for a week or so I'll mark it as closed.

    Thanks for your help!
    Jeff

  • Patrick
    • Support Monkey

    @jeff arnold

    Apart from some wild fiddling with theme options, the only files I uploaded and overwrote were the only 2 where session_start appears.

    Theme: pro3/functions/page-builder-blocks.php
    Plugin: marketpress/marketpress.php

    I also checked for simple stuff like rogue blank spaces as suggested by Jonathan above, but didn't spot any.

    I think we can chalk this one up to gremlins. :slight_smile:

  • Jonathan
    • The Bug Hunter

    Hi @jeff arnold,

    I've figured out the issue - was definitely a bug in MarketPress. I've moved the code that starts the session to execute very early in the plugin code. I'll be pushing an update soon so be on the lookout in your wp-admin dashboard. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.