Affiliate Lite 1.0.1 Problems After Install

I am using the latest version of Wordpress (ver. 2.8.5) I just bought, installed and activated your Affiliate Lite Plugin but I get many errors all over my site (mostly in the header). Here is the error I get:

Warning: parse_url() expects exactly 1 parameter, 2 given in /homepages/37/d254348151/htdocs/freedigitalcash/wp-content/plugins/affiliate-lite-1.0.1/affiliatelite.php on line 300

Please help!