Affiliate Plugin causing https warnings.

I am having trouble with the Affiliate plugin causing secure warnings when forcing https logging into admin dashboard. I think I can fix them, but would like them incorporated in the plugin permanently so that I don't have to repeat when the plugin is updated. Any help finding where these are loaded would be helpful. See below:

[blocked] The page at 'https://bsbsecure.com/wp-admin/' was loaded over HTTPS, but ran insecure content from 'http://bsbsecure.com/wp-content/plugins/affiliate/affiliateincludes/js/jquery.flot.min.js?ver=3.8': this content should also be loaded over HTTPS.
(index):1
[blocked] The page at 'https://bsbsecure.com/wp-admin/' was loaded over HTTPS, but ran insecure content from 'http://bsbsecure.com/wp-content/plugins/affiliate/affiliateincludes/js/affiliatelitedash.js?ver=3.8': this content should also be loaded over HTTPS.
(index):1
[blocked] The page at 'https://bsbsecure.com/wp-admin/' was loaded over HTTPS, but ran insecure content from 'http://bsbsecure.com/wp-content/plugins/affiliate/affiliateincludes/js/jquery.flot.min.js?ver=3.8': this content should also be loaded over HTTPS.
(index):1
[blocked] The page at 'https://bsbsecure.com/wp-admin/' was loaded over HTTPS, but ran insecure content from 'http://bsbsecure.com/wp-content/plugins/affiliate/affiliateincludes/js/affiliatelitedash.js?ver=3.8': this content should also be loaded over HTTPS.
(index):1
event.returnValue is deprecated. Please use the standard event.preventDefault() instead. load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,json2&ver=3.8:4