Affiliate Profile not showing


"Staff Access Granted"

Just tested a new user (subscriber). I (the subscriber or even a contributor) can not see the affiliate profile (on WP profile menu).

1. I can not edit my affiliate link or register as an affiliate.

2. I can not edit my profile, eg. name, email, avatar.

Please help.

Kind regards,


  • Predrag Dubajic

    Hey Victor,

    Hope you're doing well today :slight_smile:

    Thanks for granting access, I have created test subscriber account on your site and noticed that I can't access my profile at all in back end.
    Affiliates plugin shouldn't be blocking this and it doesn't work like that on my end.

    Do you have any plugin or perhaps .htacccess limitation blocking backend for non-admin users?

    Best regards,

  • Predrag Dubajic

    Hi Victor,

    WP Defender shouldn't be causing such issues, however I would like to give another test on my end with the same rules so could you post your .htaccess content in and share the URL here so I could give it a try?

    When I deactive CoursePress, my page is blank. However, uninstalling CoursePress gives the blank page.

    Note that CoursePress theme is located inside CoursePress plugin itself so if you disable plugin but leave the theme active it will cause such issues.

    Best regards,

  • Predrag Dubajic

    Hi Victor,

    Thanks, however none of those rules are making such impact on my site so it looks there's something else going on here.

    Could you provide me with FTP or cPanel access so we can dig deeper into this.

    You can send us your details using our contact form and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Best regards,

  • Adam Czajczyk

    Hello Victor,

    I hope you're well today and thanks for providing access.

    I used the credentials that you sent to my colleague Predrag but I didn't find any issues on with your WP install. I then created myself a subscriber account and noticed that it's not only that the user profile is not accessible but also the link to the profile in the toolbar is not even "clickable" for subscriber-role.

    That made me think that the user doesn't have permission to access profile and this suggested the issue on a "core level".

    It seems that either you used a plugin such as "User Role Editor" (or similar) before to change user-role capabilities or one of the plugin used in the past altered these permissions. I installed the "User Role Editor" on your site and checked "Subscriber" role capabilities and it turned out the all capabilities for that role were disabled and this essentially means that "subscriber role" users can do literally nothing on the site.

    In order to be able to access profile user has to be granted "Read" capability, otherwise he/she is rejected by WordPress.

    That said, I enabled that capability for "subscriber role" and I could then access and edit my profile and also access the "Affiliate Referrals" part of the dashboard.

    I did it for "Subscriber" role only but I left the "User Role" editor enabled. If there are other user roles affected by the same issue (as "Contributor" that you mentioned in your initial post), follow these steps:

    - as an admin go to the "Users -> User Role Editor" page
    - select user role from the list
    - make sure that the "Show capabilities in human readable form" checkbox is checked
    - select "All -> Core -> General" section from the "tree view" on the left
    - tick the checkbox for "Read" capability
    - use "Update" button to save updated capabilities.

    This will fix the issue for other roles, except for admin of course which doesn't need fixing :slight_smile:

    I hope that helps.

    Best regards,