after being redirected to the relevant user url,the content does not appear.

Users becomes redirected to the url by their roles. but once they are logged, the corresponding container will not be displayed. Is shown only error message that they need to be logged.
Before using login-with-ajax and page-restrict plugins, I removed these perhaps they were the cause of this problem. but again the same thing. I regenerate .htaccess, salt key, add wp_site and wp_home in wp_config...
Do you have any idea what i need to change else?

  • Patrick Freitas
    • Staff

    Hi Dori

    How are you today?

    Wouldn't you mind, please, try to use on your wp-config.php file

    define('NOBLOGREDIRECT', '%siteurl%');

    If the problem persists, please, enable the debug mode on WordPress, and check if any log is generated.

    On the wp-config file, comment the define( 'WP_DEBUG', false ); line using //

    //define( 'WP_DEBUG', false );

    Add those lines just above the /* That's all, stop editing! Happy blogging. */

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    References on
    https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    After enabling the debug, replicate the issue and go to wp-content folder, and check if any debug.log was generated.

    Best Regards,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Dori

    Hope you are doing well.

    This log is odd, the debug.log should only be created if there is anything to report, it shouldn't create an empty file.

    Would you mind, please run a conflict test?

    Remember, is essential that you run this test in a staging site, if you can’t do it you must create a full backup.

    Please deactivate all plug-ins, and check if the problem is gone. If so, then enable all plugins one by one and find which one is creating the issue.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!
    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.

    Here you will find more information: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let me know the results that you get,
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.