After Domain Mapping 3.1.2 site, domain shows generic IIS home page and not blog content

OK, have a sub-directory multi-site blog operational for a while now. Bought the new domain and ready to go live. So I installed Domain Mapping on my IIS box (7.5.7600.16385) with the URL rewrite module installed. I did a Network Activate of the Domain Mapping plugin, made the changes the plugin suggested (uncommenting the "define( 'SUNRISE', 'on' );" in my wp-config.php file) and adding the IP address of the server in the Network Admin settings page. And when I click on the Site Admin page for the subdirectory blog I am attempting to map and go to Tools, Domain Mapping, I see an entry that I created for:

Custom Domain
http://www.networkedlawyers.com/

Original Domain
http://blogs.fredlaw.com/socialmedialawyers/

But when I try to browse to http://www.networkedlawyers.com I only see the generic IIS landing page, not any of the blog content. When I ping by name, it resolves to the correct IP address of the server, which appears in the Network Admin settings page mentioned above.

What am I missing to get this working correctly?

  • Ovidiu
    • Code Wrangler

    I guess you missed the last part:

    Server Configuration

    Many times you may run into trouble where mapped domains don't resolve to your WordPress Multi-site install even though the DNS is correct for the domain you are trying to map. This is especially common with shared hosting. Some symptoms are getting a default or non-existant domain screen branded by your host. What this means is that your WordPress install/virtualhost is not set as the default for your IP address, so different domains do not load it up.

    Here is a very simple way to check if your hosting is configured correctly: Simply enter your server's IP address into a web browser and see if it loads up your WordPress signup page. For example, using the Edublogs IP you would enter http://66.135.63.39 into the web browser. See how it loads up the signup page? If entering your IP pulls up an error screen from your host (Example: http://74.54.219.243) here is what to do:

    Purchase a dedicated IP address for your hosting.
    Many times just the dedicated IP will do the trick. If not, you will need to tell your host to configure your WPMU virtualhost to be the default for your dedicated IP.
    If you don't mind doing some manual work when users want to map a domain, you can alternatively register each one manually with many host's control panels. This is usually called adding a "Parked" domain.

    besides that here are some more hints: http://screencast.com/t/46ydrX0L19

  • boydsavage
    • New Recruit

    And according to the NS page at:

    http://www.networksolutions.com/support/ttl-time-to-live-specification/

    They don't even support TTL values greater than 86400.

    "TTL stands for Time to Live. This is the length of time (expressed in seconds) that caching name servers will store this record in their local cache before performing a new query. TTL can be set for each Advanced DNS record type.

    Setting a low TTL value will shorten the length of time that it takes other name servers to notice that you have made a change. By default, Network Solutions sets the TTL for each record type to 7200 (2 hours). Network Solutions® allows a minimum of 3600 (1 hour) and a maximum of 86400 (24 hours)."

    I did verify that mine were set to 7200 and went back to the page printout I had this morning and made sure it said the same thing. That was more than 7 hours ago. You'd think the changes would have been propagated by now.

  • Ovidiu
    • Code Wrangler

    oops. I checked: NS records at parent nameserver: instead of NS records at your nameservers: - you're right. its set to 7200 seconds indeed.

    still, did you check that http://blogs.fredlaw.com/ is the default vhost on this machine? see the quoted part in my first answer.
    => Here is a very simple way to check if your hosting is configured correctly: Simply enter your server's IP address into a web browser and see if it loads up your WordPress signup page.

  • boydsavage
    • New Recruit

    Ovidiu, I really do appreciate all your help.

    Yes, this is a single IIS server with only one site defined, blogs.fredlaw.com which is bound to our internal IP of 10.1.5.36 and NATd to 199.45.12.208.

    However, when I browse to the IP address and not the name, I get a "The Webpage cannot be found" error. I even tried changing the binding in IIS manager to "all unassigned IP addresses" instead the one internal IP that is configured on the server. Still no love. I can browse by name (which resolves, by the way, to the exact same internal IP address), but not by IP.

    One gets the feeling that WP and IIS is an unhappy (or at least unholy) marriage.

  • Mason
    • DEV MAN’s Sidekick

    Hiya!

    @Ovidiu and @wpcdn may not be 'official' but they are none-the-less awesome :slight_smile: Thanks for pitching in guys - some mad rep points coming to both of ya.

    @boydsavage welcome to WPMU DEV! :slight_smile: IIS and WP is not fun on many levels and domain mapping can be an even worse headache. We've gotta couple folks here with some IIS knowledge though and I'm going to ask them to drop by and see if they have any further recommendations or thoughts that haven't yet been mentioned.

    Thanks!

  • daneglerum
    • New Recruit

    From what I can see the issue looks to be related more to the IIS setup than anything to do with wordpress or domain mapping. A quick check of this would be to throw a index.html file into the wordpress root directory. You'll most likely find this gets served up without issues using the internal IP you mentioned but the rest of the world won't see any change.

    As we've seen the blogs. domain is pointed to 199.45.12.208 however there is no response from that sever when pinged, navigated to in a web browser or port scanned. Essentially it looks like the server is behind a firewall or 199.45.12.208 is the wrong IP.

    You mention that you NATd an internal computer to 199.45.12.208 . Are you able to give a bit more information on 1. the process you followed for this 2. The details behind the address 199.45.12.208

    Ovidiu et. al. are correct that something fishy is happening (ie redirect) before we get to the server.

  • boydsavage
    • New Recruit

    We finally decided that after trying four different domain mapping plugins and not being able to get any of them to work on a multi-site install on IIS, that we weren't going to waste any more time. In less than a day we bought a hosting service from a company we do business with, got the domain remapped, got the whole blog including all of its customizations moved over to the new service and now we are back in business.

    I'm sure the plugins would have worked on a *nix flavor of OS, but with Windows and IIS, things just weren't working well. It was all good until we got to the domain mapping part, but that part we just couldn't solve so we cut our losses and did what we know works - a standalone WP site on it's own domain.

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Thanks for reporting back. We're working on our domain mapping plugin at the moment (along with developers of other domain mapping plugins) to try to create some better methods for handling things.

    Some things are just a pain, no matter how you slice 'em though. I think you guys made the right call in this situation.

    Thanks for letting us know.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.