After Installing WP Symposium backend login is skethy for admin (me)

On restministries.com I installed WP Symposium a couple weeks ago. Since then login on the backend has been odd. (note: my site is currently DOWN, so I know I can only get so much help until the database issue is fixed, but I am searching for some guidance in the order of what needs fixed.)

http://restministries.com/wp-admin worked a few more days then stopped logging me in. It now will only send me to restministries.com homepage (front end).

WPS support said to try http://restministries.com/login.php . Others have had this same problems and this URL to login has been the resolution.

The .php is necessary as /login sends me to the page that WPSymposium defaults to, to log people in via the front end.

But http://restministries.com/login.php randomly doesn't work either. Instead, it will go to a 500 Internal Error or other random error page.

1. Today it did not work at my first login try.
2. Then I tried http://restministries.com/admin.php (wondering if I was just crazy and had forgotten my login page) and it sent me to the homepage.
3. So I tried http://restministries.com/login.php AGAIN and the WP login form popped right up and logged me in fine.

I have had a volunteer helping me with some tech stuff and he is starting to question my sanity, sure that I am sending him the wrong login details. But since I know exactly what occurred this morning, I know he is just having the same issues I am.

Up until now I have tried to put this aside while I figured out setting up MailGun for my WP site to run for the social network to deliver mail. But now my site is saying I have a database error and need to paste something into my config file to allow it to repair. (I wrote another thread, asking about this.)

I understand while my site is down, this question/answer can only go so far.

However, I also am wondering if the login issue is somehow related to the errors I am getting on my site.

I am getting many cpanel errors where the database is being restarted. (like 7 or so today alone). I have tried to find someone on Fiverr to look at it for me, but so far everyone qualified is swamped.

So... I am not really familiar with MySql stuff. But do you think the login issue is related to this at all? Or is this another issue entirely? I can try to ask over at WPSymposium help, but I needed more details before approaching them about it, so I can make sure I get a full resolution.

Thank you!