After mapping domain how do i get it to my wordpress install so domain mapping can pick it up?

Hello guys and girls i need a little help please.

I have install domain mapping and followed it step by step and have change the domain im using to test it to the relevant ip address.

I waited and now the domain has the right ip address however just getting the server landing page.

I know its not the plugins fault and all i need to do is get my server to point the domain to the wordpress root folder.

All the info i have read is very vague or overly complicated and just wish someone could break it down step by step for me.

I have full root access and running plesk 11 so no issues regarding shared hosting etc. This word press is also the only one that will ever be run on this server, not sure if that makes a difference.

Obviously as plesk makes each domain its own section on the hardrive complete with error logs etc, please bear that in mind.

Would be great if the developer could hope in and lend a hand.

Please remember i am a novice when it comes to server admin stuff so you have to break it down for me :grinning:slight_smile:)

Cheers

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    We don't really provide so much information on the server config, generally its expected the host will deal with that because they will know their server set up best.

    You can find more information here:

    http://httpd.apache.org/docs/2.2/vhosts/name-based.html

    You would need to edit your httpd.conf file. Plesk might offer a different way to do that, but I'm not so familiar with Plesk so I'm unsure.

    You will find something for your IP address like:

    NameVirtualHost 111.22.33.44
    
    <VirtualHost 111.22.33.44>
    ServerName http://www.domain.tld
    ServerPath /domain
    DocumentRoot /web/domain
    </VirtualHost>

    You can see the DocumentRoot there, you need change that path for the IP address.

    You will want to reboot as well.

    I believe in cPanel that editing httpd.conf directly won't stick when you update Apache or rebuild the config.

    It might be worth to check with Plesk to see what happens there as well just to be safe.

    Take care.

  • Ashley Keable
    • The Incredible Code Injector

    Thanks @Tim i was struggling with the method you suggested so i had a thorough poke around the plesk admin as i recently upgraded to plesk 11 the other day.

    They now have an option to do it with a single click in backend.

    You simply select:
    tools & Settings
    IP Addresses
    and then click on the one you want and choose default domain it points too.

    Job done, no restart required and the second i pressed it now my domain mapping works.

    For once plesk has done something right and in fact the new plesk 11 seems to rival cpanel as its greatly improved.

    Thanks once again TIm hopefully this will help someone else with the same issue.

  • Jason
    • The Incredible Code Injector

    I think in laymans terms an important point to remember is this:
    Visiting your website's IP Address should give you this message.

    No site defined on this host. If you are the owner of this site, please check Debugging a WordPress Network for help.

    Once that happens, you know that wordpress is listening to all host queries on that Ip address. Then set that as your "A record" for each domain you want mapped in your DNS control panel.

    Then in the plugin, you should be able to map a domain and it should work correctly.

  • Ashley Keable
    • The Incredible Code Injector

    @scot

    Im glad this helped someone else and thanks for clearing up that this option is in plesk 10 also which probably means it may even be in earlier versions. I had a feeling it would have been however i never noticed it before upgrading. If your running plesk 10 i would recommend an upgrade to 11 as there is a great improvement in usability.

    @larceniii

    I disagree with you slightly on that one. Your ip address should be pointing to your root wordpress folder and therefore if its working correctly you would simply get the main site homepage as it picks up index.php before anything else

  • Jason
    • The Incredible Code Injector

    @Akeable

    Yes, your correct. Sorry for the confusion. The message I listed IS from the root aka wordpress install. It's a Wordpress error screen, but I'm using multi-network. On just plain multisite is shows the default network with the signup page. That's my bad!

    Sorry for the confusion everyone =D

    I have a few multisites, but lately I've been doing a LOT on my multi-network. I was confused for a sec there.

    +Jason

    P.S. BTW Why did you call out my username?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.