After super smushing my images, google pagespeed still says I need image smushing

I’ve super smushed enabled. Smush is saying that all images are super smushed. I’ve turned on development mode in Cloudflare and disabled WP Fastest Cache. Also cleared all cache. Still, Google PageSpeed Insight Tool is saying that I have a lot of images to be optimized. Site URL: lig********man.com