After updating appointments+ I am now getting a parse error

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home3/mdreams/public_html/modernmindreader/blog/wp-content/plugins/appointments/appointments.php on line 4936

I have deleted the folder, reinstalled, logged out and back in... every time I reinstall it I get a parse error. This particular plug in is one the main reasons I joined wpmu.

Please help