After upfront and parrot update can no longer freely move elements.

After the update to the parrot theme and to upfront yesterday we have not been able to freely move elements. For example, if we create a new blank region that is 800px high and we wish to place a text box at the foot of that region. The element will not stay placed and will return to the top of the region.

We have tried this on two different site and have had the same result.

Also as this update packs a lot of changes to upfront, will documentation for the new version of upfront be released, and when can we expect it?

  • Adam Czajczyk
    • Support Gorilla

    Hello Bryant,

    I hope you're well today and thank you for your question!

    The newest Upfront release brought a lot of improvements and new features. One of the new features is what I would call a "snap-to-grid" feature. This usually greatly improves the design process and makes it easier to position elements in layout.

    There's been an issue discovered today however that would result in the behavior that you described (not being able to "freely" place element). Upfront developers are working on this and hopefully this should be fixed with one of the nearest minor releases.

    The simplest workaround here would be to place additional element (e.g. of text type) in the same region above the one that you'd like to move to bottom and resize it so it moved that first one down. I just tested this on my setup and it seems to be working as expected.

    Best regards,
    Adam

    • Adam Czajczyk
      • Support Gorilla

      Hello Claudio,

      The issue that was originally reported here should no longer be here so even if it's the same or very similar behavior we'd need to check your site. Please join our live support chat session at any time that suits you and we'll assist you with this.

      Kind regards,
      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.