After upgrading from 3.9.9.8 to latest, i was editing

After upgrading from 3.9.9.8 to latest, i was editing settings of a feed. In particular, the open links in new window option. Upon saving it, I received,

Fatal error: Cannot use object of type WP_Error as array in /home/bitcoin/public_html/wp-content/plugins/autoblog/autoblogincludes/classes/Autoblog/Render/Feeds/Table.php on line 112

Now feeds dont show in the admin panel, just the error above.

I did disable all the add on features in an attempt to solve this, as well disabled and reenabled the plugin itself, no success.

Let me know how to fix this.
thank you
Drue