After Upgrading the Pay with a Like Plugin, it stopped working and I am getting a "fatal error&

I am now seeing this messages on the posts that had the social paywall --

Fatal error: Call to undefined function has_shortcode() in /nfs/c04/h01/mnt/165728/domains/customercommunications.com/html/wp-content/plugins/pay-with-a-like/pay-with-a-like.php on line 488

--

If the new Pay With a Like is not compatible with WordPress Version 3.5.1 is there a way to go back to the old plugin?