After wordpress update, Upgrade Network not working

Fublish.net my primary multi site install was broke while updating. I fixed it by disabling & then enabling plugins via FTP.

WP has got upgraded. BUT when I try to upgrade network, the below error appears.

Warning! Problem updating http://fublish.net/akshaychaitanya. Your server may not be able to connect to sites running on it. Error message: cURL error 7: couldn't connect to host

Pls help solve this.

Thank you.

  • James Morris

    Hello Ganesh,

    I hope you are well today. Thank you for your question.

    After taking a quick look around, there seems to be some issues with your installation. The IP address was not set in domain mapping, I'm unable to view your Network Setup or settings, and with the exception of two sites that have mapped domains, all of your subsites are returning 404 errors.

    In order to help you better with your issue, would you please grant me access to your server?

    Please visit the Contact page and complete the form with the following information:

    Select "I have a different question" from the drop-down box.

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - Admin login:
    Admin username
    Admin password
    Login url

    - Domain Registrar Login
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    - link back to this thread for reference
    - any other relevant urls

    Best regards,

    James Morris

  • James Morris

    Hello Ganesh,

    I hope you are well today.

    After logging in and taking a good look around I did find a couple things, otherwise your site is working properly.

    The first thing I found is you kept getting a large number of out of memory errors in your DEBUG output. I've been able to resolve this by increasing WordPress' maximum memory with the following in your wp-config.php

    define('WP_MEMORY_LIMIT', '512M');

    Next, you are getting some session notices regarding a plugin you have installed.

    [15-Oct-2016 15:39:16 UTC] PHP Warning:  session_start(): open(/var/php_sessions/sess_b4835b07002a8385337602ead44ce931, O_RDWR) failed: No such file or directory (2) in /[truncated_path]/wp-content/plugins/geodirectory/geodirectory-functions/geodir-class-session.php on line 280
    [15-Oct-2016 15:39:17 UTC] PHP Warning:  Unknown: open(/var/php_sessions/sess_b4835b07002a8385337602ead44ce931, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
    [15-Oct-2016 15:39:17 UTC] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions) in Unknown on line 0

    I have not done anything to correct this as it would require removing the geodirectory plugin. You may want to consider finding an alternative to that plugin.

    Now, about your original issue... I've verified that the akshaychaitanya subsite is indeed being upgraded. The Upgrade Network function only updates the database of your subsites. The actual file updates are done under Network Admin -> Dashboard -> Updates.

    Note: I've also performed a plugin conflict test and all seems to be well there also.

    All my tests suggest the upgrade process is working, but the warning persists. I've been able to verify that the primary site and all subsites are working correctly.

    I did find in your system information that you are running a very old version of PHP (5.3.29 to be exact). The current stable and supported version of PHP is 5.6.x.

    Could you please contact your hosting provider and ask them to update PHP to the currently supported version and see if that resolves your problem?

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.