"All Done!" but don't save the changes

Hi there!

I managed to edit the blog's menu, but not the rest. I change it, "All Done!", but it doesn't really save. What can be happening?

  • Nastia
    • Support Rock Star

    Hello NasirNatália , hope you're doing well!

    Could you try to replicate the same with all the other plugins deactivated? If everything is well, activate one plugin at a time to find the one that causes this.

    If the issue still persists, would you please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Kind regards,
    Nastia

  • Denitsa
    • WordPress Warrior

    Hey there Natália,

    I logged on to your website and could see some MySQL errors there.

    The "MySQL server has gone away" error means the database server keeps timing out or otherwise closing the connection. Are you on a shared hosting?

    You can try fixing that by logging on to your server via FTP and navigating to the /wp-includes folder, where you need to open the wp-db.php file. Search for a $this->ready = true; line.
    Just below it add the following

    //WP Query Gone Away Error Fix
    $this->query("set session wait_timeout=600");

    If that does not help you might want to contact your hosting provider.

    I was able to create a new page via Upfront and then edit it and all went well. It's the wpmu-dev-test-page/.
    Strangely, those load if put after index.php like so: https://your-website.com/index.php/wpmu-dev-test-page/
    So the problem here isn't with Upfront, it's with your permalinks structure and you'd need to change that if you don't want the index.php thing:

    Let me know how it goes!

    Best regards,
    Denitsa

  • Sajid
    • DEV MAN’s Sidekick

    Hello Natália,
    Hope you are doing good today :slight_smile:

    I could not access your WordPress Dashboard because of error establishing database connection issue on your site (see screenshot). So I could not really debug this issue.

    Please make sure you have it configured correctly and your database server is accessible (not down).

    When this issue is sorted, then enable support staff access and post a reply here so we could investigate this issue.

    Take care and look forward towards your response Natália :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.