"All images are smushed" but also "0 IMAGES SMUSHED"?

Hello,

I've installed and used WP Smush successfully on one site but can't seem to get it to work on another.

I'm getting both these messages: "All images are smushed and up to date" and "0 IMAGES SMUSHED" (I'm a photographer and have had that site for years, so there are definitely more than 0 images).

If I scroll down the plugin page to the bottom of the settings, the wheel is constantly turning next to "checking images…" — I've tried leaving it for hours but nothing happens.

When I try to smush an image individually via the media library, that doesn't work either.

As far as I can tell I'm doing everything the same way I did with my other site, which worked perfectly with no problems at all.I love how the plugin's been working on my other site, so it'd be great to see how it does with my main site. Any help would be much appreciated!

Cheers,

—Rachel

  • Sohag Ronjon Dey

    Hi Rachel,

    Hope you are doing well.:slight_smile:

    I have gone through your admin and found that both the smush and smush pro is installed in your site. I have deleted those plugins and re-installed the pro version. But I have found there are console errors which suggests to be an issue with setup,

    >(unknown) Mixed Content: The page at ‘https://yoursite.com/wp-admin/upload.php?page=wp-smush-bulk' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://yoursite.com/wp-admin/admin-ajax.php’. This request has been blocked; the content must be served over HTTPS.

    Ajax URL is printed by WordPress itself, Smush just uses it. Please check your https settings.

    Please let us know if you need any further help.

    Cheers,
    Sohag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.