All images missing from Wordpress Multisite

This is the 2nd time this has happened to me. Last time it was an issue with security on the wp-includes folder preventing the wp-files.php script from doing it's job. I've checked permissions, .htaccess, and that file and can't figure it out...

All images are missing from all subdomains (mapped or not). Main site has images.

Help!

  • Tyler Postle

    Hey Narasopa,

    Hope you're doing well today and thanks for your question!

    Are the images not in the folders at all? Or just not showing up in the media library within WordPress?

    Have you tried re-saving your permalinks?

    Are the permissions on your image folders readable? By default they are usually set to 755.

    Look forward to hearing back!

    All the best,
    Tyler

    PS. Did you make any changes before it happened? Add any new plugins/themes etc.?

  • narasopa

    So, this is an actively maintained network. The biggest thing I did recently was change wp-admin settings back to 'original domain' in multisite mapping. However, I reverted that setting and it didn't seem to matter.

    I also noticed some wierd file permissions, and fixed them, but still no joy.

    As an example, http://justinhandley.com/files/2014/03/justin-round.png is a link to an image that should work. The image is there at http://justinhandley.com/wp-content/blogs.dir/76/files/2014/03/justin-round.png

    I had this issue before and it was a permissions issue with wp-files.php, but that isn't the case this time.

  • narasopa

    OK, so I have fixed this, and I thought I'd post a little checklist here for any other unlucky soul that runs into this. The information available via google, the wordpress forums, etc is misleading and very hard to get through. There are basically three possible issues here.

    This time, for me, it was my wp-config file - a wierd character had gotten pasted in when I was adding an api key for a network activated plugin.

    So, things to check are...

    1. Did you recently edit your wp-config? If so, roll it back. Then try again, checking or wierd spaces, bad commenting, etc. Make sure your file editor doesn't add a space at the end.

    2. Does your .htaccess work? In httpd.conf - do you have AllowOverride set to All and Options set to All or at least to include files?

    3. Does your ms-files.php work. This is only for people who have been using multisite since before 3.5, but if that is you, this file can cause issues. One thing I've experienced is 'hardening' the wp-includes folder with Sucuri - that broke it as the ms-files.php could no longer work. Is there a .htaccess in your wp-includes, or are the permissions on the folder set in a way it can't execute on your server?

    Between those three things you should be able to quickly sort this out if you also have this problem.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.