All post excerpts are suddenly the same

Very strange issue.
My customer created a new blog post and all of a sudden, all previous posts show the same excepert on the standard archive page (https://ein-neuer-weg.com/blog )
This happens with all plugins disabled and even with a standard WP theme.
It does not affect archive pages I create with BeaverBuilder, using their "Posts" module. The single posts are not affected.
The excerpts shown are always from the latest post, so if I delete the newest post, all excerpts change to the next one.

Any suggestions how to sort this out?

WP 5.0.3, BeaverBuilder (Plugin, Theme and Themer), Polylang.

  • Pawel
    • Staff

    Hello Christian,

    Sure, that does look strange!

    From what I've seen by looking at the page, there's no obvious sign as to why this is happening. Each post should have its own excerpt - either written by the post author or just the snippet taken automatically from the beginning of the post. There may be something else doing this, maybe some code or some kind of error that we can't see on the frontend of the site.

    I'd like to take a look at the cause of this issue. Would you mind allowing support access so I can have a closer look possible causes?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this ticket once access is granted.

    cheers,
    Pawel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.