All RSS Feeds Across Network Are Gone

We recently noticed that every single site in our network has lost its RSS feed. No feed exists at https://themajestysmen.com/feed/ or any other site on the network. We first noticed it because we're using Ultimate Branding's option of Dashboard Feeds and I first noticed a feed widget on a dashboard returning this:

RSS Error: A feed could not be found at https://themajestysmen.com/info/blog/feed/. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed.

I've tried everything I can think of (such as checking php closures and stuff). I'm not sure what SimplePie is referring to. The only thing I can think of now is that this was noticed within a week of moving our whole network to a new server. Not sure why all the feeds would have gone missing, but I can't think of any other change that we've made that would do this. Any ideas? I'll go ahead and open the Support portal for the network.

  • Nithin
    • Support Wizard

    Hi Riley with SOZO.DO,

    I checked the site via support access, and I could notice the anomalies as listed in your ticket description. The following error, only means it's not able to find the feed:
    RSS Error: A feed could not be found at https://themajestysmen.com/info/blog/feed/. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed.

    This could happen due to many factors, like an existing plugin causing a plugin, or something specific within the server side.

    Could you please take a copy of .htaccess file, and then make sure you only add the following rules to the file, and see whether it works fine?

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    If you still have the same issue, I'm afraid, a conflict test would give a better idea what could be causing this. Is this a live site? Is it possible for you to run a conflict test as shown in the flowchart given below, and see how the feeds behaves?
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Please let us know how that goes. Have a great day ahead. :slight_smile:

    Regards,
    Nithin

  • Riley with SOZO.DO
    • Webprenuer

    We've now reset the whole .htaccess file and it didn't do anything. We even asked the server company if there was anything they did to cause that (cause it was different) but they said the .htaccess file wouldn't affect the RSS feeds anyway. They claim RSS feeds are totally run by php scripts in WordPress and would work even without an .htaccess file and I do think that's true. But, still, why aren't these working these RSS feeds working? Is there anything else at the server level that could interfere with them?

    I've run a compatibility test using the Health Check plugin to turn off all Plugins on one of the sites. I also set that site's theme to the default Twenty Nineteen. Emptied the Hummingbird caching. Nothing works at all. We can't figure this out.

    Is there any change it could be related to something with Hummingbird and cdn, caching, or any of that stuff? Can't figure out what's causing this. I still have a suspicion it's at a server level but I can't guess what that'd be. Please help!

  • Riley with SOZO.DO
    • Webprenuer

    The Health Check plugin returns this on each site:

    The loopback request to your site failed, this may prevent WP_Cron from working, along with theme and plugin editors.
    Error encountered: (0) cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

    Would that have anything to do with these RSS feeds disappearing? I've tried to search to see if RSS depends on wp_cron or "loopback requests" and it seems it might, but I honestly don't know what a loopback request is.

  • Nithin
    • Support Wizard

    Hi Riley with SOZO.DO,

    Thanks for sharing your observation, if you could confirm the .htaccess is clean, then it has to do mostly with one of the existing plugins. Since you did try running conflict test, and still the issue occurs.

    Could you please check whether enabling debug mode helps in having a better idea about what could be causing this.

    To enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to load couple of the feeds on your subsite where it's loading blank pages, and also try creating a new test subsite, and see whether you still get the same issue in there too. Once done the releated errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice weekend ahead. :slight_smile:

    Kind Regards,
    Nithin

  • Riley with SOZO.DO
    • Webprenuer

    Hey all. So we discovered that we had been maliciously compromised and apparently the same malicious hack scripts were breaking our RSS feeds. I still don't understand how and why it was affecting our RSS feeds, but as we cleaned up everything the feeds started working. So I guess I'll mark this closed. That was why, even though we don't know exactly what effect it was that messed up the feeds.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.