All the units from my courspress have dissapear

Hi, I'm very worried. I installed Course press pro a year ago and I put all the material for 2 online courses. I never had a problem during this year some days ago (I don't konw exactly when) all the material dissapear (content, videos, pdf, everything! for the 2 courses), I don't understand what happened. Then I thought I had install the new version for the courpress plug in, i did it and all my website dissapear. I have tried twice. I have to restore a back up copy of my website. But the units are not there.

  • Kasia Swiderska

    Tim Hello Monica,

    It seems that you are using 1.3.4.3 version of the CoursePress and you updated WordPress to 4.8.2 - since this is outdated plugin version we are not able to fix that for it.
    Right now, as temporary solution I can advise to roll down WordPress to 4.8.1 so CoursePress will start working again in current version.

    Our next step will be to create a staging site (if your hosting provider doesn't have this feature you can use this plugin https://wordpress.org/plugins/wp-staging/ ). When we have staging site we can do CoursePress upgrade to version 2 - see what is failing on site and try to fix that, and then we can update to WP 4.8.2 - and if then everything will work we can move staging to live or repeat everything on live site.

    When you have staging site please send in the following via our secure contact form https://premium.wpmudev.org/contact/#i-have-a-different-question :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress staging admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Mónica,

    Please never post credentials to your sites on forum - those threads are public - that is why we ask for credentials via email.

    Please check your staging site if everything is how it should be. I updated everything there.

    For some reason I wasn't able to generate debug log so I'm not sure what caused this 500 internal error.
    This is what I have done on the staging site.
    1) I updated CoursePress
    2) I updated WordPress
    3) That gave us a 500 internal server error...
    4) I disabled all the plugins by renaming plugin directory in the wp-content
    5) I was able to login again to site.
    6) I reverted change done in point 4) and in the same time I also renamed coursepress directory to disable coursepress
    7) Having access to wp-admin I updated everything what was to update
    8) I enabled all the plugins that were recently disabled
    9) I enabled CoursePress at the end.

    There is no more 500 internal server error and by looking at the list of courses units are still there. Can you confirm?

    kind regards,
    Kasia

  • Monica

    HI Kasia,

    First of all thanks for your help. I have checked my staging site and everything seems to work.

    With regards to coursepress and the courses and units, they are still there but what i don't understand is: when I do a preview of each unit, I only see the text but not the videos nor the audios, does it mean that when the students get in will see the videos and the audios or not?

    If you can answer this question as yes, they will see them, then I understand that the next step is that all that you have done in the staging site do it in my site..? I understand thi is secure as this is why you've done the text in the staging site...

    Let me know,

    Thanks again Kasia,

  • Kasia Swiderska

    Hello Monica,

    With regards to coursepress and the courses and units, they are still there but what i don't understand is: when I do a preview of each unit, I only see the text but not the videos nor the audios, does it mean that when the students get in will see the videos and the audios or not?

    Can you give me a example of that? I'm checking now on clone site, preview and I can see videos

    If you can answer this question as yes, they will see them, then I understand that the next step is that all that you have done in the staging site do it in my site..? I understand thi is secure as this is why you've done the text in the staging site...

    Yes, that would be steps to replicate on live site. But before any change you need make sure you have a backup of the site. You can use our Snapshot plugin to create backup, or any other plugin that provide this functionality.

    Another solution (if your hosting provider allows for that) is pushing staging site to live site - but that depends if there were changes on live site after creating a clone site (like new users registering, new students enrolling to course, students taking courses). If there were changes like that, then this is not a valid option.

    kind regards,
    Kasia

  • Monica

    Hi Kasia,
    My hosting people could made the change. So the clon site is now my live site.
    Things that I see that are not working well:
    1- I have a user and a password as a student and when I get in through my students area in my website, I don't go to the courses but to my dashboard.... So this is something that it has to be solved.
    2- The Embarazo consciente course is working fine
    3- The Sanar la relación con la madre course something is wrong. When I get in and try to do the next page button a wibndow is opened saying: 'this course is completed you cannot submit answers anymore' and then I can't continue to the next page.
    I had to change my password for the clon site as i couldn't get in. Do you need the new password? the user is the same: monicamanso
    If you need the password let me know where should I send it to you as I can't put it here.
    Thanks,
    Mónica

  • Kasia Swiderska

    Hello Monica,

    Things that I see that are not working well:

    Can you confirm that all those issue were not present on staging site before you copied it to live site?
    I understand that before doing that you checked staging site to see if everything is working there as suppose to do.

    Please send again credentials using method described here https://premium.wpmudev.org/forums/topic/all-the-units-from-my-courspress-have-dissapear#post-1278848 - new admin user password and test student account - I will check those issues.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Mónica,

    Please, never post credentials to site in thread - always use mail form. I removed credentials now, but make sure you will change password.

    1- I have a user and a password as a student and when I get in through my students area in my website, I don't go to the courses but to my dashboard.... So this is something that it has to be solved.

    Huh. Unfortunately, this is bug. I checked this on my test site and option for redirecting is not networking. I'm reporting this to developer so they can fix that.

    Right now I can suggest using this plugin https://premium.wpmudev.org/project/login-redirect/ - you will be able to set redirect to selected URL in Settings -> General.

    3- The Sanar la relación con la madre course something is wrong. When I get in and try to do the next page button a wibndow is opened saying: 'this course is completed you cannot submit answers anymore' and then I can't continue to the next page.

    Reason that there was this message was option to end date course was checked

    I selected "This course has no end date" and it is working again.

    kind regards,
    Kasia

  • Monica

    Hi Kasia,
    "Huh. Unfortunately, this is bug. I checked this on my test site and option for redirecting is not networking. I'm reporting this to developer so they can fix that."

    So when should I expect this to be fixed?? When is the developer going to do it?

    "Right now I can suggest using this plugin https://premium.wpmudev.org/project/login-redirect/ - you will be able to set redirect to selected URL in Settings -> General."

    Before I try to do this (I have to dedicate some time), please answer me the first question. All this thig is taking soooo long!

    Hope to solve everything this week
    MM

  • Kasia Swiderska

    Hello Monica,

    So when should I expect this to be fixed?? When is the developer going to do it?

    I'm sorry, but I am not able to provide any ETA at the moment. I know that developer was checking this issue already, and if there will any hot fix for this bug I will post it in thread. But in case hot patch is not possible, then it will be released in future CoursePress release.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Monica,

    I'm afraid I can't provide exact ETA when this bug will be fixed. Our developers are working on many tasks, some are more complex and time consuming than others, so it is hard to estimate when plugin with fix will be released. Before we release plugin it will be tested by our QA team, to double check if reported bugs are fixed correctly.

    Sometimes it is possible to provide hot patch to bug when it is change in one, two plugin files - but it not always the case, and then we need to wait for full release of plugin.

    We do our best to fix those issues as soon as possible, but there is many factors that influence time of providing permanent solution.

    kind regards,
    Kasia

  • Monica

    HI Kasia,
    with regards to this issue:
    1- I have a user and a password as a student and when I get in through my students area in my website, I don't go to the courses but to my dashboard.... So this is something that it has to be solved.

    Just to let you know that My webmaster has finally solved the problem. So everything is working fine now. There is no need that your developers do anything else. This is important, now that finally everhything is working, I don't want anyone else to touch my web for the moment.
    Thanks for your help.
    MM

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.