allowed memory size

Why does this happen and how can i fix this?

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 30720 bytes) in / on line 233

I tried to fix it 2 weeks ago and ended up reinstalling everything. i put too much work into now and just can't do that again...

I have read other posts about changing settings in php.ini file and wp-settings.php file but I don't have a file and my hosting company says i should just create one... but I am not sure what to put in it and I don't know what or where to add the memory settings in wp-settings.php...

  • Aphrodite
    • The Reaper

    That comes from your hosting plan.

    This is a PHP.ini parameter that you cannot change unless you have a VPS or dedicated server. Ask your ISP if it is possible to upgrade the value to at least mmmmm 128 Mo ! (I have 256 on my server).

    What is you server admin pannel ? are you on vps/dedicated ?

  • drmike
    • DEV MAN’s Mascot

    Well, at least you searched. :slight_smile:

    In the root of your wp/wpmu install, create a file named php.ini.

    Open it up for editing and put this in there:

    memory_limit = 128MB

    Save it and try that.

    Gotta admit though that's a two second fix that your host should have done for you since it's on their end. They shouldn;t have passed it back to you.

    Edit: Gotta admit though that you're already at 64megs probably from your error. Something's eating up memory over there. Do you have any caching in place?

  • drmike
    • DEV MAN’s Mascot

    In WHM, I *think* is one of the settings for options when you compile Apache but I don;t have a CPanel box to test. We're Direct Admin in house.

    And even then, I;d be editing the file directly.

    I;m going to pass on explaining how to do that until we get sharena.conte straightened out though. Less confusion. :slight_smile:

    edit: Just to make her feel good, I'll bump this up to the Advanced subforum. Many an experienced tech has hit up against this and had to figure out how to solve it.

  • slpconte
    • Design Lord, Child of Thor

    thank you dr. mike. from trying what i have learned through my searches i have created a php.ini file and increased to 64MB. this has not seemed to help. how would i set up or check for caching settings? i am sorry that i am clueless but i just moved to wordpress from joomla and had been using joomla for 5 years....

  • AltisonaMedia
    • Site Builder, Child of Zeus

    It's nothing to do with the amount of space you are taking up but more to do with the demands you are putting on processing php code - basically running php queries

    Have you got a lot of plugins installed? Are you bloating your current theme with lots of extra functions? Are there any you don't need to have? A lean site is an agile site....

    Interesting to hear that you have moved to Wordpress from Joomla, I am moving a site from Drupal to Buddypress (even the thought just fills me with relief)

  • slpconte
    • Design Lord, Child of Thor

    hmmm... it worked earlier today and now it does not. I can't even get to my admin page.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 30720 bytes) in /home/livinggr/public_html/ on line 3582

  • Aphrodite
    • The Reaper

    Did you have any other exchange with your hoster ? If he told you it's easy as A B C he could do it !

    you really need at least 128 Mo :slight_frown:

    I use 256 on my server.

    Huh try adding define('WP_MEMORY_LIMIT', '128M'); to your wp-config.php

    it "can" work on some servers....

  • greenplanetfilms
    • Site Builder, Child of Zeus


    Unfortunately that is a Band-Aid (brand) fix. You just happened to delete a plugin that puts your memory usage below the threshold. But memory usage can vary depending on a number of factors.

    I'd suggest working with your hosting company to resolve this. It definitely does involve them. If they don't allow enough memory to run PHP apps effectively, then you can face this issue in the future.

    Just my .02.

    Good luck!

  • karencatangay
    • WPMU DEV Initiate

    I am experiencing the same problem and I am already thinking of upgrading to VPS since my host said I cannot go beyond 64M with my current plan. But it's quite pricey for me. I use hostgator right now and the reco minimum plan with cpanel is about $50/month fee (coming from $10/mo)

    Is there any other alternative hosting service that's cheaper than this (but with good customer service, live support preferred)?

  • JoseffB
    • The Crimson Coder

    I'm on Go Daddy Grid Hosting which is great for large sites but terrible for small sites. I'm actually thinking about going to Host Gator when my contract is up. I pay about 200 for 1 yr with lots of benefits but I'm willing to go to Host Gator at 500 a year just to get good service & good support.

    So, that elongated answer servers to say sometimes you need to pay more for good performance AND good support.

  • karencatangay
    • WPMU DEV Initiate

    Thanks for the reply. Yup, happy with hostgator service so far that's why it's not that easy to shift. But just wondering if there's a more affordable alternative that also supports well. For newbies like me who are still exploring different tools/services, expenses just build up so fast. But of course, will keep hostgator if there's no other company that compares.....

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.