An IP address

An IP address checks if the CloudFlare enabled on a site which overloads the CPU usage.

Log:

181.224.143.12 - - [09/Mar/2018:12:45:29 +0100] "HEAD /?wphb-check-cf=true HTTP/1.0" 200 - "https://www.k...-e....nl/?wphb-check-cf=true" "WordPress/4.9.4; https://domain"
181.224.143.12 - - [09/Mar/2018:12:45:29 +0100] "HEAD /?wphb-check-cf=true HTTP/1.0" 200 - "https://www.k...-el....nl/?wphb-check-cf=true" "WordPress/4.9.4; https://domain"
181.224.143.12 - - [09/Mar/2018:12:45:28 +0100] "POST /wp-cron.php?doing_wp_cron=1520595928.8951671123504638671875 HTTP/1.0" 200 - "https://domain/wp-cron.php?doing_wp_cron=1520595928.8951671123504638671875" "WordPress/4.9.4; https://domain"
181.224.143.12 - - [09/Mar/2018:12:45:29 +0100] "POST /wp-cron.php?doing_wp_cron=1520595928.9882509708404541015625 HTTP/1.0" 200 - "https://domain/wp-cron.php?doing_wp_cron=1520595928.9882509708404541015625" "WordPress/4.9.4; https://domain"
181.224.143.12 - - [09/Mar/2018:12:45:29 +0100] "HEAD /?wphb-check-cf=true HTTP/1.0" 200 - "https://domain/?wphb-check-cf=true" "WordPress/4.9.4; https://domain"

In one day that website executed over 207000 executions.

  • John Roeland
    • WPMU DEV Initiate

    We have a workaround that seems to work for now. We disabled the WP_CRON int wp-config.php and setup a cronjob on the server every 30 minutes to run the script wp-cron.php in the root directory.

    It looks like that slowed it down quite a lot.

    The wp cron executes every time a page is loaded. Seems like Hummingbird is checking the page constantly causing this script to run multiple times.

  • splaquet
    • The Incredible Code Injector

    I don’t mean to hijack your thread, but this might be what’s causing my error.

    I have two multisite installations having an issue with the CloudFlare feature in hummingbird. both sites were previously on CloudFlare, but now neither are. When I updated to the latest version of hummingbird on both sites, it’s showing CloudFlare as now being enabled. It seemed to turn itself on, and now I can’t seem to turn it back off. In fact, it’s not letting me change the CloudFlare setting to Apache or any other setting. (well, I can change it, but it won’t save and reverts back on refresh)

    I’m including a screenshot below.

    I uninstalled hummingbird, looked through the DB for any CloudFlare references, and reinstalled. CloudFlare option was still turned on and I couldn’t turn it off! ????

    Maybe the site is pinging CloudFlare, seeing that there’s an account on CloudFlare (not connected at all), and forcing the option on?

    I cannot figure it out, but this thread seems to be closest match to my issue… as weird as it sounds

    [image pos=”0″]

  • Dimitris
    • Support Star

    Hello there splaquet,

    hope you’re doing good today! :slight_smile:

    As this is an issue about CPU overload, did you notice these as well?

    If not, I think this is a separate issue, even though these can have a common root. In this case, please do reach us in our live chat or create a separate thread in our support forums, as we’re keen on having separate threads per issue and per member.

    Warm regards,

    Dimitris

  • CO134
    • New Recruit

    We experienced similar issues to what John Roeland described, after updating a development environment. The configuration from production, which uses Hummingbird/Cloudflare, was implemented on dev and produced a significant strain on the dev server. Nginx/PHP-FPM logs mostly include the following requests:

    * /?wphb-check-cf=true

    * /wp-admin/admin-ajax.php?action=http_worker&nonce=[redacted string]

    Disabling Hummingbird (using WP CLI since the site was returning 5** error in the browser) was a viable workaround for us since it was just a dev environment.

  • slydawgg
    • WPMU DEV Initiate

    I have spent the last 36 hours trying to figure out why one of my sites was getting maxed out with Entry Processes, and going through the error logs I found

    * /?wphb-check-cf=true

    I deactivated Hummingbird and immediately my Entry Processes went from 49/50 to 2/50…

    • Dimitris
      • Support Star

      Hello there slydawgg,

      hope you’re doing good today! :slight_smile:

      Is this happening with latest HummingBird version? Please advise!

      March 14, 2018 – version 1.8.0.4

      Fix: API spam issue

      Fix: Performance scans not returning any results on some hosts

      Fix: High CPU usage with wphb-check-cf checks

      Warm regards,

      Dimitris

    • Dimitris
      • Support Star

      I’m really sorry for the outcome here. You should be seeing some /?wphb-check-cf=true checks, as HummingBird is checking for Cloudflare status, but you shouldn’t be getting like thousands of lines with these logs.

      In order to escalate this to our developers, could you please Calvin Eidt share some server credentials with us? As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

      Subject: “Attn: Dimitris

      – WordPress admin (login url/username/password)

      – FTP credentials (host/username/password)

      – cPanel/Plesk credentials (host/username/password)

      – link back to this thread for reference

      – any other relevant urls

      Keep in mind the subject line as ensures that it gets assigned to me. We will also need to briefly activate HummingBird during the tests.

      Warm regards,

      Dimitris

      • Calvin Eidt
        • New Recruit

        I stand corrected, having looked at a couple of our other sites it does look like the update has made a difference. Sorry about that.

        The issue that caught my attention though is that someone is running a deep scan of one of our larger sites and many of these deeper pages don’t have a valid cache generated due to low traffic to them. WordPress and Hummingbird are not only generating a page and caching it, but also running this Cloudflare check at the same time.

        Is it not possible to have this as a configuration option, “I use Cloudflare Yes/No”?

        We do not use Cloudflare at this time so having a redundant check running continually like this is quite a waste.

        • Dimitris
          • Support Star

          Hello there Calvin Eidt,##1

          hope you’re doing good today and really appreciate the feedback here! :slight_smile:

          Good things that initial reported issue is resolved for you, very pleased to know that!

          As for the extra check for Cloudflare, I’ve already informed HummingBird’s lead developer about this, so we’ll keep you posted about any insights on this.

          Take care,

          Dimitris

        • Dimitris
          • Support Star

          Hi there Calvin,

          I’ve got some feedback from our developer about Cloudflare checks (and I quote):

          HummingBird is going to query Cloudflare only on admin pages. HummingBird needs to check, if Cloudflare is connected and this is something that will be improved more in version 1.8.1.

          Warm regards,

          Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.