"Android library project can not be launched" error when

"Android library project can not be launched" error when i trying to run android appication

  • ross
    • New Recruit

    sorry had to post that there as the photo box wouldnt move.

    When i go back into wp-android properties Jac, which i had set up earlier i see the 2nd screen shot with everything unchecked. I try and check them and apply but Eclipse is not having it. Then i noticed in the 3rd screenie that its possible not editable.

    Is it me or just the latest version of eclipse being differant to the documentation? I notice that i cant see 'Android Virtual Manager Launcher' in Eclipse. only 'Android Virtual Device Manager'. Seems the same options as per the documentation after that though so maybe not that.

    Im just editting the plugin itself from you untouched with no errors (like there was when i changed a few pics)

    Just cant run this bugger

  • Jack Kitterhing
    • Code Norris

    Hi there @ross,

    Hope you're well today and thanks for your question! :slight_smile:

    From your screenshots your missing a couple of files, most notably action bar sherlock.

    Is this a fresh import? Would you mind sending me the app please to contact(at)wpmudev.org so I can check it. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • ross
    • New Recruit

    Thanks Jack. I had a few days off trying as it was ''doing my head in'. Just deleted everything and trying again. Again i will just be using the 'workspace EDUblogs' as per WP1 attached picture. Already youll see im 3 files down from the demo intruction picture 'wp2'

    I will continue non the less and add more pics of any differances etc

    Using the workspaceEdublogs workspace as per wp3

    No 'ok' button and no Android Developer Tools (wp4)

    I will now open the SDK Manager in folder adt-bundle-windows-x86_64-20140702 ,,,no i wont ill open it via Eclipse>>WIndow>>>Android SDK Manager....bah im confusing things again...errrrr ok wp5.jpg shows what i have installed in Android SDK Manager

    im leaving the images as they are for ease sake for now just so as i now how to start and finish this

    Now IMPORTING PROJECT as per wp6.jpg

    Ecllipse now looks like wp7.jpg

    Right clicking on wp-android>>>>properties (see wp8.jpg)

    The Clean all projects then file restart. ill stop here for now. phew

  • ross
    • New Recruit

    on restart everything looks fine and im not sure i used to have that android bit in the console. maybe things are ok? we shall see lol

    "Click The Android Launch Manager" it says in the instructions but we dont have that as per wp10.jpg. I presume android virtual device manager is the same thing.

    wp11.jpg my emulator settings and ive started it and seems no probs there. Right now we get to the bit i was stuck on before.....yip still the same problem (wp12.jpg)

    BAck to your original questions Jack i am just using the default edublogs workspace with no alterations as per above. I think Eclipse might have changed its way of doing things since the guide was made. I could send you the app if you wish but as i say i havent changed anything from the download.

  • Jack Kitterhing
    • Code Norris

    Hi there @ross,

    Hope you're well today and thanks for the additional information, looks like the additional libraries are getting removed.

    When you right click wp-android > properties do you still see action bar sherlock and menu drawer? If you do uncheck "is library" and click apply, then go to project > clean and it should work. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.