Another BP plugin dead - Buddypress links

Hi

I am VERY ungry !

This nice plugin, one BP more, is dead. Forcefully, it broke all my bp networks on the last update of WP :slight_frown:

Deprecated: Function split() is deprecated in /home/carnets/public_html/wp-content/plugins/buddypress-links/bp-links-core.php on line 223

I am bored with that stuff :slight_frown:

Just to mention it... DONT USE IT !

  • Mason
    • DEV MAN’s Sidekick

    Hiya Aphrodite,

    Ugh. That sucks. With the delays in the BuddyPress release I do think we've seen a slow-down in development for BuddyPress plugins. That being said, there are also still plenty of active developers working on this platform.

    I'd expect that we'll see a lot of new interest with the releases of BP 1.3 and 1.4. They're both shaping up to be incredible!

    Thanks for the note/warning here though about BP Links.

  • Toni
    • The Incredible Code Injector

    Thanks for the warning Aphrodite.

    Sucks Big Time!!!

    I was going to invest more time in getting the plug-in to work for my site, glad I saw the warning now!

    Does anyone here like the sound of WPMU DEV Links? +1?

  • Richie_KS
    • HummingBird

    yeap..heard you there...first the buddypress privacy and now this....hopefully
    the buddypress album still continuing developing cause i really love it...and
    with the new buddypress version due release...compatibility issue will be at
    hand along with wordpress 3.2+

  • Richie_KS
    • HummingBird

    no worry..the bp album just got updated recently so the development still on going..i was just
    hoping they can continue the dev progress on the plugin:slight_smile:..with some bp plugin discontinue recently...you never know:slight_smile:

    well cross finger...hehe

  • Aphrodite
    • The Reaper

    So do I !!!

    Andnow obliged to supress bp links from 2 production networks and lost many links and comments :slight_frown:

    That just for a deprecated function (split), used in 3 lines in 2 files, which i am unfortunatly totally unable to fix myself :slight_frown:(((((((((((

  • Tammie
    • WordPress Wizard

    I'd caution those being alarmist about BuddyPress dying or plugins also dying. Perhaps you need to look at getting more involved in the community itself because BuddyPress is very vibrant and a lot of those plugins and functionality is coming into core things. 1.3 has some exciting new features and 1.4 is just simply amazing as to the changes that are already planned.

    Simple thing is support those plugins you love... donate, buy and even get involved. The ones that died 99% were because of lack of community support and people just taking for free without donating or support the developer. That is not saying anyone in this conversation is part of that but it's a fact. After all an open source community is in a huge part down to those that get involved. You do not have to be a coder to get involved either. Testers, designers, translators, documentors and many other roles are always welcome.

  • Toni
    • The Incredible Code Injector

    Terry you raise some important points here,

    personally I admit that I have no time to help developing buddypress itself (will look into the translator job you mentioned though) but I am making sure to support the plug-ins that I use and couldn't do without...

    It's true that 99% of the time the reason is lack of support :slight_frown:

  • tuckspop
    • WPMU DEV Initiate

    Need some advice here.

    I am presently building a site, probably buddy press. Now I am concerned about using plug ins other that DEV plug ins. Is this a legitimate concern? I am so new at this and just need advice.

    When is the new version of buddy press due out?

    I am really excited about the site I want to build, but I don't want to build it twice.

    Mike Carlson

  • Aphrodite
    • The Reaper

    Ohhh yes it is MUCH legitim...

    Just have a look on the last update of the plugins you want, the number of downloads, the comunity.

    I broke many things using just greeeat but.... dead plugins (gropblog is a terrible example :slight_frown: )

    Be very very carefull with bp plugins....

  • tuckspop
    • WPMU DEV Initiate

    Thanks Aphrodite,

    But the question. If they are not DEV plugins, what is a good rule of thumb, looking at downloads, community, etc... Too new to know what to even look for.

    That is the primary reason that i joined here.

    Mike Carlson

  • Toni
    • The Incredible Code Injector

    yes looking at the last update date is a real good indicator..

    I understand your concern tuckspop me too I still worry a lot...

    Generally when they break they don't mess up parts of your site but it can happen when you rely too heavily on them yes...

    Not sure when the next buddypress will be released but I believe within the next couple months...

  • tuckspop
    • WPMU DEV Initiate

    I hate to ask stupid questions, but I am a little confused. The New Blogs Template plugin is said to work with Buddy Press, but I thought that you could only have one blog on Buddy Press and that you need to go to Multi Site for additional blogs.

    Additionally,

    I am wondering how to download the bbpress platform. Not quite sure what it is, but you need that platform for one of the edublogs theme.

    Now having said that, is the new forum plugin for wordpress pretty stable and basically accomplish the same thing as having a separate "edublogs" forum type theme.

    Mike Carlson

  • Mason
    • DEV MAN’s Sidekick

    Hiya Mike,

    I thought that you could only have one blog on Buddy Press and that you need to go to Multi Site for additional blogs

    That is correct. You must have multisite installed to use New Blog Template. The reference to BuddyPress only means that you can have BuddyPress installed and NBT will continue to work. Not all of our plugins work with BuddyPress installs.

    I am wondering how to download the bbpress platform. Not quite sure what it is, but you need that platform for one of the edublogs theme.

    http://wordpress.org/extend/plugins/bbpress/

    This is the new plugin version. The theme you're referencing was for the older (still used here on this site and by BuddyPress) bbpress stand-alone version. With the new plugin being released there's a lot changing and the edu-knows theme will either be completely re-worked or abandoned as it won't be compatible.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.