Another oh Sh*t moment, pro-site stripe payment fail, site says it went through

So I have a customer who e-mailed me saying an email was sent to them from my site via pro-sites saying they need to update their payment as the payment failed.

Checking stripe and indeed the payment failed.

Checking my prosites admin area for that site...and it says the payment went through and was extended for another year.

So...whats going on here, did i find another bug...?

I want that $2** payment from my client., whats the proper solution so that nothing messss up any further and I can guide my client to paying and keeping the subscription on track

Thanks.

  • Adam Czajczyk

    Hello Ben!

    I'm sorry for causing confusion! I initially posted wrong response here (I messed responses to two different threads) and I completely forgot that you get the notification email. I guess I was too much in hurry. I apologize for it.

    The response posted here is the one that's "valid".

    That being said, thank you for your replay and additional explanation. The "short term fix" that you proposed may be a solution here but I'd like to ask you for one more test: could you please try to signup for a new site - using stripe payment - yourself? You may want to switch Stripe temporarily for to a test mode or just use it in "live" mode and "pay yourself".

    I'm asking you for that because I'm not able to test in "Live" mode and I wouldn't want to "mess up" anything by switching your live site to "test" mode.

    It would be great then if you could make such a test and let me know if the payment went through and site got created as expected (make sure that you are setting up a new site).

    Best regards,
    Adam

  • Ben

    Adam Czajczyk

    I don't think you will be able to work through this on your own, I would like the developer to let me know when he has time to review this, then I can email him the logs of stripe so he can work through the logic of the problem to see where the failure is in the scenario where in an annual subscription the site gets renewed when the payment fails.

    I'd like his feed back and the go ahead for the work around to get this guys payment asap.

    Thanks

    Ben

  • Adam Czajczyk

    Hello Ben!

    Thank you for your replay.

    I do understand that you don't believe in my ability to work on this but please believe that my main and only goal here is to help you. That's why I'm asking these questions. I just need to gather as much information as possible to provide developer with possibly complete set of data that may be useful for them. In case like that when developer's intervention is necessary, this is what I should do in order to provide you with help. I'm sure you understand that.

    That being said, I'll forward all these information to the developer along with access data to your site. Please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/

    Select "I have a different question" from the drop-down list. 

    Please be sure to make a full backup of your entire site first!

    Once you provide me with above information I'll engage one of the developers and pass all the information to him. He'll then either contact you directly or pass his questions/information through me or one of my colleagues from support team.

    Kind regards,
    Adam

  • Ben

    Adam Czajczyk

    More to add to the conversation

    Had another person who said their site went down on a month to month

    Went to look at her account, and the payment actually failed on 8/12/2016, but for some reason the site renewed anyways even with the payment failure, but this month on 9/12/2016 it finally disabled the site.

    Now with this same client she said she put in all the info but saw no response (so i told her to do it agan and it worked)

    Reviewing the stripe logs i see the message:

    Your card's security code is incorrect.

    So perhaps in addition to this bug, there is an also an issue with the CVC error handling (unless she just didn't see the error message in which case perhaps the error messages need to be more visible.

  • Dimitris

    Greetings Ben,

    hope you're doing good today! :slight_smile:

    Contact form info sent with related webhook request data and related sub blog

    I just read your email sent to Adam, but I can't locate the followings:
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin

    Could you please reply to this email providing us this details too?
    Looking forward for this in order to ping our dev team. :slight_smile:

    Warm regards,
    Dimitris

  • Ben

    Predrag Dubajic

    Well I'm glad they are finally doing a legit code review if that is the case, this plugin has a great feature set...however has been bugged up and unreliable since LAST june as you can see by reviewing my threads...with the worst kind of bugs...silent bugs that break in the background without notifications and in special scenarios.

    Please keep us up to date on the progress and inform the community of what to look out for.

  • Lindeni Mahlalela

    Hello Ben,

    I am sorry for delay delay on our side, as my colleagues have said we are dealing with a lot of other similar issues and we give them priority from oldest to newest.

    I would like to find out if you are still having this issue or not, if the issue still persist I will am here to help resolve it with you. I have accessed your website's dashboard and WordPress admin with the credentials you have given to us. Unfortunately, I need some details about the websites you are having issues with on your network.

    Please list the websites having issues and the error logs from stripe and WordPress so I can analyze the logs and see what went wrong. Once I have this information I will try to replicate the issue and hopefully come up with a solution.

    I have also noticed that you have Pro Sites version 3.5.5-beta1 installed, does that version fix the problem or you are still testing it out on your network? Please let us know if this version addresses the issue or not.

    I hope you enjoy your day further.

    Cheers,
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.