Another Plugin Error with Appointment+ Does it ever stop??!!!

Every Time but really ever Time I setup your Appointment+ with a Website to synch it with Google App Calendar there is some type of Error, why can your Developers not Develop a Plugin that works without all these Errors?

Seriously frustrated over this.

Any way, I have another Error that comes up again, the Developer that does my Website thinks it is the Plugin that causes the error, see Details Below, hope you can give me a quick fix on how to solve that without making it complicated.

[9:09:49 PM] Abhilash singh: Appointment updated done
[9:09:58 PM] Abhilash singh: configuration done
[9:10:14 PM] Abhilash singh: but getting this error ""
[9:10:40 PM] Abhilash singh: "Insert went wrong: Error calling POST https://www.googleapis.com/calendar/v3/calendars/on-call-business.ch_s8rvt3d0u67m5aolg0lgrjqtj4%40group.calendar.google.com%29/events: (404) Not Found"
[9:12:01 PM] Dario Cucci: weird, dont understand why that is
[9:12:55 PM] Dario Cucci: It looks like it has to do with usage limits but we have not used the Calendars as much so I don't understand this error
[9:13:16 PM] Dario Cucci: It also shows as unauthenticated us
[9:13:20 PM] Dario Cucci: use
[9:13:32 PM] Dario Cucci:
"error": {
"errors": [
{
"domain": "usageLimits",
"reason": "dailyLimitExceededUnreg",
"message": "Daily Limit for Unauthenticated Use Exceeded. Continued use requires signup.",
"extendedHelp": "https://code.google.com/apis/console"
}
],
"code": 403,
"message": "Daily Limit for Unauthenticated Use Exceeded. Continued use requires signup."
}
}

By The Way it does not Show in your List the Plugin Appointment+ to choose from but only Custom Sidebars Pro and Dashboard of Wpmudev, so that is not working either.
Regards

Dario Cucci

    Tyler Postle

    Hey there Dario,

    Are you using a google apps for business email address? Google puts restrictions on their business email accounts which can cause the above problem. So it's best to use a personal @gmail.com address for the apps+ gcal integration.

    If you're already using a personal gmail account then can you go into your Google API project and generate a new .p12 key, upload that to your /wp-content/plugins/appointments/includes/gcal/key/ folder. You can leave the old one in there or delete it, doesn't matter

    https://code.google.com/apis/console/

    Then copy the new .p12 key file name(excluding the .p12 extension) and copy that into your Appointments+ > Settings > Gcal. p12 key field.

    Then do a test appointment and see if it works correctly.

    If not, then create a brand new project and replace all the apps+ gcal settings with those from the new project

    If you need any help setting this up then just let me know.

    By The Way it does not Show in your List the Plugin Appointment+ to choose from but only Custom Sidebars Pro and Dashboard of Wpmudev, so that is not working either.

    It looks like you have 2 versions of the same site added to the dashboard. www and a non-www version. It looks like your site uses non-www by default.

    You can remove the www version here: https://premium.wpmudev.org/wp-admin/users.php?page=wdpun

    The dashboard recognized you as posting from the www version and it only displays the plugins installed on that site, which it sees is only Custom Sidebars and our Dashboard. Remove that site from your list then it should see it as the non-www version again.

    Hope that helps! Look forward to hearing back.

    Cheers,
    Tyler