Answer to a Question is not Registering

Question 31 of the first unit has been set up with an answer in admin. We have tried to submit the answer repeatedly, but the answer never registers in the Admin student workbook.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @rogera,

    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. I could replicate this issue on your website also found the root cause why its not working (yay....).

    The issue is that in the answer you have single quote in members. Yes PHP is that stupid. I am marking it as confirmed bug and notifying the developer so it can be fixed in next version of this plugin.

    Meanwhile please remove that single quote from text for example it will be members instead of member’s and it should work fine.

    Thanks for bringing it into our attention, sending some points your way for appreciation. Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Roger Allsopp
    • Site Builder, Child of Zeus

    Sajid, I need you to check your diagnosis of this problem. Whilst auditing the remaining questions, I found this one (attached), which is Question 4 from unit BSBWOR202A. This question has been answered, has an apostrophe in one of the responses, yet the answer has not failed to record in the workbook?

  • Sajid
    • DEV MAN’s Sidekick

    Hi @rogera,

    Hope you are doing good today :slight_smile:

    I tested again on your website and its still not working with exact following string.
    The abilities of the team member's, time restrictions, preferences

    When I removed the apostrophe and it worked just fine for me. But yes, I can see what you mean its working on other questions. Its sporadic issue and thanks for providing more details. I am passing on this information to the developer of this plugin to find it the exact issue and fix it out in next version.

    I tried to replicate the same issue on my own website and could again replicate it. However when I remove the astrophe it works.

    I have updated the developer with latest information and I am sure it will help him figure this out quickly. Meanwhile please remove the astrophe from this answer or in any other answer you get this issue.

    Thanks for being helpful and have a nice day :slight_smile:
    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi @rogera,
    Hope you are doing good today :slight_smile:

    I am sorry but its still not fixed. I have pinged the developer again and update this thread when I have more details from developer.

    Thanks for your patience and being a valuable member :slight_smile:
    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.