anti-splog 1.0.6 doesn't believe in wp 3.1

I upgraded WP to 3.1 (from 3.0.5), BuddyPress to 1.2.8 (from 1.2.7) and everything is working fine. Then I upgraded anti-splog from 1.0.5 to 1.0.6, following the directions to remove it from mu-plugins and put it in plugins. Upon attempting to activate, I'm getting an error message that reads:
This version of Anti-Splog is only compatible with WordPress 3.1 and greater.
WP3.1 is correctly and fully installed. I ran the network update already, no problems there. The header on home and the feed indicates a generator of wordpress 3.1. But I can't reactivate anti-splog.

If this were a site that only rarely got spammed, I wouldn't mind so much. But without anti-splog enabled I get a couple hundred splog signups a day.

Please, any help you can offer is apprecaited.

Thank you.