Anti-Splog?

I'm already starting to get spammers to my new forum site. I just tried to install Anti-Splog but I got an error. I'm not using Multisite but I am using Buddypress. I guess you must use both for Anti-Splog?

If I can't use Anti-Splog, what solution do you recommend? Please advise.

TX.