Anti-Splog cannot activate with my key

I just get this message:

Anti-Splog is not fully enabled. You must enter your WPMU DEV Premium API key to enable the powerful blog and signup checking. More info» Dismiss

There was a problem connecting to the API server. Please try again later.

Settings Saved!

Anyone know why? I tried now to reset the key but it didn't help....
I have used it before buy I forgot to pay my membership so now when I've paid and try to add it again it's not working.

(Could not find it in the plugin list here in the support so I put this in General, sorry)