Anti-Splog is not fully enabled. You must enter your WPMU DEV Premium API key

I get this when trying to configure it on a new site. This is a multisite domain and I see it listed under "Your Registered Multisite Servers:". What am I missing or doing wrong?

Any responses appreciated.