Anti-Splog - There was a problem connecting to the API server.

I just registered a multisite domain and tried to activate the API key for anti-splog but it keeps giving "There was a problem connecting to the API server. Please try again later."

This is on a server hosted @ linode.com running apache.

I've looked at other posts here but none of them provided any specific solutions besides checking the your key and making sure the domain was registered here. Any other suggestions? Do I need specific ports open for this?

This plugin is one of the main reasons I purchased the elite membership and I'm bummed I can't start using it yet.

Thanks

-Matt

  • mattbaya

    Hi - OK I looked through that post and tried a few things. It's not DNS, it looks up the correct IP though I did try adding it to /etc/hosts in case the speed difference would help.

    I can ping premium.wpmudev.org fine too

    Traceroute gets to 10ge.xe-1-0-1.sat-8500v-sbdis-1.peer1.net (216.187.124.82) on it's 22nd hop and then doesnt get any further, though I tested this from another server, my home machine and my work desktop they all stop after this hop too.

    WPMU DEV Update's API key works fine, and I downloaded Anti-Splog 1.1 and installted it and ran the update through the WPMU DEV Update interface and that worked fine too.

    What setting would I need to put in my php.ini to allow POST method? This is a gentoo linux server hosted at linode.com and I have root on it so any suggestions are welcome.

    Thanks
    -MAtt

  • Timothy Bowers

    When I run a Traceroute I get:

    15  10ge-ten1-2.dal-eqx-cor-2.peer1.net (216.187.124.117)  164.766 ms  163.453 ms  162.448 ms
    16  10ge-ten1-3.sat-8500v-cor-2.peer1.net (216.187.124.178)  169.609 ms  166.839 ms  167.902 ms
    17  10ge.xe-1-0-1.sat-8500v-sbdis-1.peer1.net (216.187.124.82)  169.473 ms  169.717 ms  171.638 ms
    18  premium.wpmudev.org (66.135.49.214)  170.800 ms  169.423 ms  167.952 ms

    So your not getting premium.wpmudev.org (66.135.49.214) from any location?

    I'll ask Aaron if he has any other ideas on that.....

  • mattbaya

    From the server in question at Linode:

    10  10ge.ten-1-3.atl-101mar-cor-1.peer1.net (216.187.115.38)  20.757 ms  20.875 ms  20.854 ms
    11  10ge-ten1-3.atl-telx-cor-1.peer1.net (216.187.120.225)  21.124 ms  21.084 ms  21.049 ms
    12  10ge-ten1-2.dal-eqx-cor-2.peer1.net (216.187.124.117)  40.738 ms  40.432 ms  40.592 ms
    13  10ge-ten1-3.sat-8500v-cor-2.peer1.net (216.187.124.178)  47.810 ms  47.707 ms  47.700 ms
    14  10ge.xe-1-0-1.sat-8500v-sbdis-1.peer1.net (216.187.124.82)  49.483 ms  49.474 ms  49.461 ms
    15  * * *
    16  * * *
    17  * * *

    From my work desktop @williams.edu;

    9  ae-3-3.ebr2.dallas1.level3.net (4.69.137.121)  44.606 ms  44.531 ms  44.963 ms
    10  ae-92-92.csw4.dallas1.level3.net (4.69.151.165)  44.161 ms  45.194 ms  50.037 ms
    11  ae-1-60.edge9.dallas1.level3.net (4.69.145.16)  44.320 ms  44.085 ms
        ae-3-80.edge9.dallas1.level3.net (4.69.145.144)  44.311 ms
    12  peer-1-netw.edge9.dallas1.level3.net (4.59.118.6)  44.269 ms  44.454 ms  43.889 ms
    13  * * *
    14  * * *
    15  * * *

    From my home machine on Time Warner cable in Williamstown, MA

    19  ae-1-60.edge9.dallas1.level3.net (4.69.145.16)  65.023 ms
        ae-3-80.edge9.dallas1.level3.net (4.69.145.144)  65.379 ms
        ae-4-90.edge9.dallas1.level3.net (4.69.145.208)  68.025 ms
    20  peer-1-netw.edge9.dallas1.level3.net (4.59.118.6)  68.917 ms  65.086 ms  66.713 ms
    21  10ge-ten1-3.sat-8500v-cor-2.peer1.net (216.187.124.178)  74.236 ms  74.505 ms  73.939 ms
    22  10ge.xe-1-0-1.sat-8500v-sbdis-1.peer1.net (216.187.124.82)  76.393 ms  76.622 ms  78.215 ms
    23  * * *
    24  * * *
    25  * * *

    From my other server in Detroit

    10  * ae-1-60.edge9.Dallas1.Level3.net (4.69.145.16)  26.606 ms  26.362 ms
    11  PEER-1-NETW.edge9.Dallas1.Level3.net (4.59.118.6)  36.691 ms  36.883 ms  36.629 ms
    12  10ge-ten1-3.sat-8500v-cor-2.peer1.net (216.187.124.178)  43.515 ms  43.511 ms  43.404 ms
    13  10ge.xe-1-0-1.sat-8500v-sbdis-1.peer1.net (216.187.124.82)  44.891 ms  47.214 ms  46.770 ms
    14  * * *
    15  * * *
    16  * * *

    Another server in detroit;

    9  ae-91-91.csw4.Dallas1.Level3.net (4.69.151.161)  26.086 ms * *
    10  ae-3-80.edge9.Dallas1.Level3.net (4.69.145.144)  26.018 ms * *
    11  * * *
    12  10ge-ten1-3.sat-8500v-cor-2.peer1.net (216.187.124.178)  43.163 ms * *
    13  * * *
    14  * * *
    15  * * *

    That's all the machines I have access to, or at least all the unique locations. I'm just typing 'traceroute premium.wpmudev.org', let me know if I should be putting any commands to go with that or if you'd like me to use any other commands.

  • mattbaya

    Well can you give me any leads on what I would be looking to adjust here? I have root on this server and as far as I know our firewall is just via a setting for iptables where it's limiting incoming ports etc. Or could this be a setting in php.ini? Any hints or URLs for more info would be greatly appreciated.

    Another helpful thing would be an easy way to test if POST requests are blocked, ideally via command line or a short script so I could use that as a specific example if I have to contact linode support etc.

    Thanks

    -Matt

  • mattbaya

    Here's the thing, linode just provides the virtual server, no setup or install. I set this server up with a co-worker, both of us are professional linux administrators. It's running the latest Gentoo linux install and has been working fine for us for a number of wordpress sites up until tryng to get this plugin working.

    This server only has iptables as it's firewall, and the php setup is pretty standard, so I'm pretty surprised this is the problem. That's why I asked for an easy way to test and prove that http post requests are being blocked cause I really am surprised to hear they are.

    I really appreciate the responsiveness here on this forum and want to thank you for all your help so far. I realize that there's only so much you can do but I also am a bit frustrated since I just paid for the elite membership, mainly because of this plugin. If there's any other advice or tests you can suggest to help figure this out I'd be very grateful.

    Thanks

    -Matt

  • Cole

    Hey Matt, sorry about the issues you are having. I'm coming in a bit late on this so I'm not sure if someone has asked you to do something similar to this but if you could add the following code to anti-splog.php at line 726 directly after the $response = wp_remote_post($ust_api_url, $args); line.

    $debug = var_export($ust_api_url,true);
    $debug .= var_export($args,true);
    $debug .= var_export($response,true);
    wp_mail('youremailaddress@you.com','Anti-Splog Debug', $debug);

    Naturally replace your email address try adding the API key again and if you could forward the email that you should recieve to cole@incsub.com I might be able to help a bit further. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.