Anti-Splog: Users can't register public blogs

With the Anti-Splog plug-in activated, users are unable to register new blogs. Registration is working fine, but once registered - and I've been able to verify this - they can't create new blogs marked public.

Disabling Anti-Splog works fine. (I deactivated Anti-Splog and reactivated BP-Humanity, the other plugin I've been testing for this purpose.)

What typically can cause that error? How can you control what Roles / at what time users can register blogs, generally? (obviously, being able to block blog creation on initial signup can be another way to discourage splogs, if we did have more control)

This is BP 1.2.6.

  • Mason
    • DEV MAN’s Sidekick

    Hiya peter,

    I haven't seen this error before. Can you tell us the settings you're using for this plugin? What message are users seeing when trying to create a new blog?

    To control new roles for Signups you could try this plugin:
    http://wordpress.org/extend/plugins/new-blog-default-user-role/

    I haven't tested it with BuddyPress, but users here have reported success with a regular WordPress multi-site install.

    Hope this helps. A bit more information and we'll help ya get the anti-splog issue sorted as well.

    Thanks!

  • drmike
    • DEV MAN’s Mascot

    Can you define by what you mean by "they can't create new blogs marked public." Are they getting some sort of error? Sent back to the home page?

    Giving a link as well as a check of your webserver;s error logs would also be a plus. Most support forums operate in such a manner.

    Can you also walk us through how you;ve installed the anti-splog plugin as well please?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.