Anti-Splog will not accept the API key

Hi all:

When trying to activate the anti-splog plugin, it keeps telling me that:

There was a problem with the API key you entered: "Your Multisite Domain is not yet registered for this API Key. You are attempting to connect from

and then my domain.

I've rechecked the WPMUDev profile and see that mydomain.com is registered (not http://www.mydomain.com) but I'm still being rejected. I've checked spelling, copy/paste errors, typos etc.

I'm running BP 1.5 beta 3 on WP 3.2.1 - is this just a BP 1.5 compatibility issue?