Anti-Splog WP 3.1 Requirement

Uhh... just attempted activating the new Anti-Splog version 1.0.6 that appeared in my WPMU Dev Updates and got the following error:

This version of Anti-Splog is only compatible with WordPress 3.1 and greater.

Plugin page lists WP 3.0.4 as min. requirement.

Any others we should know about?