Anti-Splog/Registration page

ever since i installed anti-splog it has thrown off my registration page: http://bit.ly/fncOKs... i am using the scholar theme...

see picture how the url for the sub-domain is on the same line as "blog title" and the "i" in "I would like my blog to appear in search engines" should have started on the next line...

and the white background stops right after "name"...

help?

  • JoseffB
    • The Crimson Coder

    I think this is in the file ust-wp-signup.php. I notice that there is the following style sheet:
    <style type="text/css">
    .mu_register { width: 90%; margin:0 auto; }
    .mu_register form { margin-top: 2em; }
    .mu_register .error { font-weight:700; padding:10px; color:#333333; background:#FFEBE8; border:1px solid #CC0000; }
    .mu_register input[type="submit"],
    .mu_register #blog_title,
    .mu_register #user_email,
    .mu_register #blogname,
    .mu_register #user_name { width:100%; font-size: 24px; margin:5px 0; }
    .mu_register .prefix_address,
    .mu_register .suffix_address {font-size: 18px;display:inline; }
    .mu_register label { font-weight:700; font-size:15px; display:block; margin:10px 0; }
    .mu_register label.checkbox { display:inline; }
    .mu_register .mu_alert { font-weight:700; padding:10px; color:#333333; background:#ffffe0; border:1px solid #e6db55; }
    </style>

    I usually use firebug to filter out and override the style sheet in the child themes CSS or sometimes actually inline edits.

    I think Barry is closest to this plugin and he may have more light to shine on it.

  • Mason
    • DEV MAN’s Sidekick

    Hiya gina,

    This is happening because the input field is set to 98%. Normally this is an appropriate dimension as it'll make any word wrap to the next line and still leave a bit of space so as not to bump right again the edge of the div. Of course, the one letter that'll give ya trouble is 'I'.

    To fix this you can either make the width of the input field 100% or add a small margin to bump that I down with the rest of the sentence like this:
    #blog-details input[type="text"] { margin-right: 2px; }

    Hope this helps. Thanks!

  • JoseffB
    • The Crimson Coder

    @masonjames Your awesome dude!

    @gina as mentioned in other post the bitly style links are often filtered out on networks because they may be porn or hacker related. This is the case on most of the networks that I am on. So I meant I needed the actual URL of the site rather then the Bitly url.

  • Mason
    • DEV MAN’s Sidekick

    @JoseffB Sometimes ;D

    @gina try this:
    .standard-form { background: #fff; padding: 6px; }
    #blog-details, #supporter, #antisplog, #signup_submit {margin-left: 6px; }

    The first line adds the white background to the entire form. The second line adds brings in the custom registration properties inline with the default WordPress ones.

    You may also want adjust the ToS width using #tos-content

    Thanks!

  • gina
    • The Bug Hunter

    thanks mason!

    i hope you don't mind but you are kinda my "go to guy" for these types of things.. but i have one more.. on the front page of the site in the right hand column under "spotlight" do you see how the "read more" and "flag this post" is overlapped?

    what should i do to move the "read more" to above "flag post"

    i am using bp moderation for the flagging... i wish there was an option to not flag admin posts/pages.. but there isn't... as far as i can see.

    happy new year!!!

  • gina
    • The Bug Hunter

    thanks mason!

    that is weird... yes i do still have it activated... and ijust checked it and i still see the two links overlapping.. so does the "spotlight ad" show up in the right hand column for you?

    thanks :slight_smile:

  • Mason
    • DEV MAN’s Sidekick

    Hiya gina,

    Doh! Logged in. That explains it.

    It's definitely a CSS issue, but I'm not able to see it, so I can't be of much help here. Tammie may be able to comment further on this, but if you're actually using the Spotlight area to display ads it may not be an issue in the future.

    Otherwise, if you can make it available to see for visitors or provide a demo login we can get it sorted.

    Thanks!

  • gina
    • The Bug Hunter

    ok - the original problem i thought was fixed.. isn't totally fixed...

    now the top username/password login for the theme has a white background because it also uses the .standard-form { background: #fff; padding: 6px; }

    and the input fields are huge and still throw everything out of whack... i so don't want to go theme hunting again... *sigh* - how can i fix this and make the changes in my child theme so when i update this theme i won't have to keep editing this?

    thanks again...

  • Mason
    • DEV MAN’s Sidekick

    Hiya gina,

    Here's something else you could give a try:
    #signup_form { background-color: #fff; padding: 6px; }
    #blog-details { margin-left: 6px; }
    #blog-details input[type="text"] { display: block; }

    As with any of this, there's more than one way to do these things. This should give you the white background and move the text to the next line. The entry fields still will go all the way across (which I think is what happens by default)

    If you haven't already, grabbing up a copy of firebug and keeping it close will help you make these customizations to your liking!

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.