AntiSplog Server Connecting Problem

This website is a freshly installed on our own server. I have tried many times inputting the API Key but still getting “There was a problem connecting to the API server. Please try again later.” Please give me some guidance.

  • Predrag Dubajic
    • Support

    Hi Nicholas,

    Thanks for granting access, I can see the issue on your site, the API seems correct and I’m unable to replicate same behaviour on my sandbox site.

    Can you try going to your WPMU DEV account page here https://premium.wpmudev.org/hub/account/ and reset API key.

    Try using your new API key and see if it works after that.

    Please note that changing API key will log you out of WPMU DEV dashboard on all your sites so you will need to log in again.

    Best regards,

    Predrag

  • Nicholas
    • Recruit

    Hi Predrag,

    I have resetted the API Key already. It didn’t solve the problem.

    However, another problem arose. I could not log into WPMU Dev Dashboard for some of my web sites, namely leapa.net, ipadrental.hk and rentipad.hk

    This error appeared:

    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”:404}}

    The URL to this is:

    https://premium.wpmudev.org/api/dashboard/v1/authenticate

    So, would it be a problem with my WPMU Dev account?

  • Predrag Dubajic
    • Support

    Hi Nicholas,

    Huh, this is really strange…

    Could you provide us with WP admin details to all your sites with issues, Anti-splog and login problems, and also include WPMU DEV login details so we can investigate what’s going on here?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select “I have a different question” for your topic so it doesn’t go back to forums – this and the subject line ensure that it gets assigned to me.

    Subject: “Attn: Predrag Dubajic

    – Site login url

    – WordPress admin username

    – WordPress admin password

    – WPMU DEV username

    – WPMU DEV password

    – Link back to this thread for reference

    – Any other relevant urls

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Nicholas,

    Wow, this is really a strange one, everything looks fine with your account and I’m not sure what might be causing it.

    I will check with our sys admins to check it out as well and see if I’m missing anything.

    In the meantime, can you try installing Anti-splog on some of your other sites, that are hosted on different server and see if it works there, this way we will know if it’s related to account or server itself.

    Best regards,

    Predrag

  • Nicholas
    • Recruit

    Thank you for the suggestion.

    I have another web site which has MultiSite enabled (but it is essentially a single site). It is on a shared host running the latest WP on PHP 5.3. Well, I couldn’t even get Anti-Splog installed. On the WPMU Dev Dashboard, “Server error status: error [0]” appeared after waiting for a minute or so @@

  • Nicholas
    • Recruit

    After numerous trial and “Server error status: error [0]”, I’ve finally got Anti-Slog installed into the ‘trial’ site. I have also successfully registered the site and punched in the API Key.

    Hmm … really strange. The ‘trial’ site has been running for years and there are many plugins and unused themes there. Quite a lousy backend. However, the new site is a clean fresh install with nothing on it.

    I just spotted the major difference between the two. The old ‘trial’ site runs on PHP 5.3. The new site runs on PHP 7. So, would it a PHP version issue?

  • Adam Czajczyk
    • Support Gorilla

    Hello NIcholas!

    PHP 7 should work well so it shouldn’t create a problem.

    In case there’s an API connection issue there are some things worth checking first:

    – is CURL enabled on your server?

    – are its certificates up to date?

    – is “allow_url_fopen” PHP option set to “on”?

    – are there any firewall rules on the server that may be blocking connection?

    For some (or all) of those issues you may need to get in touch with your host provider and they should be able to set that for you.

    There’s also another “trick” worth checking in case none of the above is the solution. It requires adding following line to the “wp-config.php” file of your site:

    define( 'WPMUDEV_CUSTOM_API_SERVER', 'https://premium.wpmudev.org/' );

    That said, I think it would be worth to check the sites against issues listed above.

    Best regards,

    Adam

  • Nicholas
    • Recruit

    Hi Adam & Predrag,

    Thank you very much for your suggestions! It works now!

    Here is how:

    – is CURL enabled on your server?

    This is the tricky part! CURL is installed and I verified it by curl -V So, I expected php-curl should be working as well. But … it’s NOT @@

    – are its certificates up to date?

    It is a new server. The cert new. So it is up to date.

    – is “allow_url_fopen” PHP option set to “on”?

    Yes. No matter on or off, same error. Can’t find any debug info about this.

    – are there any firewall rules on the server that may be blocking connection?

    The firewall is on, but no rule has been set yet :p

    — Nick

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.