Any problems with WordPress 3.5?

I am waiting to see what problems are popping up with wordpress 3.5 before updating, is anyone having any difficulty?

There seemed to be several issues being solved just prior to the release and I am skeptical about them being adequately fixed.

Folks online are reporting problems creating new posts, adding media and with tags; deactivating all plugins and reactivating them one at a time until they all check out or fail can be a real pain in the bottom.

Any WPMU Dev reports of problems?

tlcorbin

  • Paul Barthmaier
    • Code Wrangler

    Hi Tlc!

    Boy, does 3.5 want me to be sarcastic and say something like, nope, everyone is all good and the negative reports and all fabrication! But, alas, it's not to be true. There are, in fact, plenty of issues, but some are just cosmetic and minor. Others are more serious. If you can hang on a little while longer without updating that may be prefereable. I would expect something soon and perhaps you can leap frog any potential issues. I just wish my OCD didn't get the best of me! I read somewhere once that patience is a virtue, but, it was really only once, and I"m pretty sure that was fabrication too!

    Hope this helps. Let us know if you get stuck somewhere.

    Cheers,
    Paul

  • euDigital
    • Design Lord, Child of Thor

    Don't know if it's related to WP 3.5 upgrade, we had to do it manually in one site... the one that uses marktetpress, but since the update we're unable to edit Marketpress products, creating new ones works fine, updating newly created also fails (500 error).

    Everything else works.
    We already disabled or fixed all the plugins not 3.5 ready (wpdb::prepare() missing 2nd argument mainly)

    We're now going to do a downgrade to 3.4.2 to see if it goes back to normal.

    *extra info: quick edit works fine, editing and updating causes the error

  • tlcorbin
    • Able1

    Hello guys, from what I read online I thought it would have been prudent to polish the prize another week, rather than rush to publish and wind up looking like Microsoft.

    I have enough on my plate right now, and don't want any extra troubleshooting chores. I may wait until 3.5.1 before updating; but I doubt it.

    tlcorbin

  • euDigital
    • Design Lord, Child of Thor

    it's a marketpress / server configuration problem, we did a clean install of wp3.5, added marketpress, created a product, tried to edit and it fails when updating (http error 500), we don't have access to the apache logs and if we turn any kind of logging on, marketpress give s way too many notices/warnings :slight_frown: i think we'll wait for wp3.5.1 and if it takes too long we'll restart on a fresh WP v3.4.2.

  • tlcorbin
    • Able1

    Hello, Purple_dude, I noticed that from my primary dashboard, when I click on the wpmudev link, it displays very erratically, as in the toolbar displays about a third of the way down the page. It is very annoying.

    Unhappily, it appears my concern is justified. I am sure a fix will be forthcoming and quickly, but I would stick with 3.4.2 until more of your specific issues are resolved. This could have very negatively impact on your clients and reflect badly on your services-but you know that already. Please keep me posted about this issue and its impact.

    tlcorbin

  • euDigital
    • Design Lord, Child of Thor

    we added a "back to backend" link to our 500 error page if the referrer url is xxxx/post.php, while we wait for updates or some more info. The product does get updated :slight_smile:

    update: duh, the "clean install" wasn't so clean after all, my colleague added WPML, and it seems that wpml was causing the problem, without it the 500 error is gone. We had quite a few WPML plugins, trying to track the problem now...

    update2: the problem resides in the "wpml marketpress" plugin, we got back to the main site, disabled only that plugin, and edit works ok... but we need it. Going to check that plugin code for known problems with wp 3.5... maybe i should visit their support forum first :slight_smile:

  • tlcorbin
    • Able1

    Hello, Purple_dude, I do believe that you are on the right track now. When I went to the support forum earlier my spider senses started twitching, because there appeared to be a small mountain of issues that had not been resolved and yet they planned on releasing the new 3.5 version on schedule, microsoft style, and a bad idea from my viewpoint.

    OK, I have to ask, how did the interesting handle Purple_dude come about?

    tlcorbin

  • euDigital
    • Design Lord, Child of Thor

    I forgot how bad the wpml support forums are :slight_frown: will give it a try but i better continue to track the problem myself, no apache logs, turning php log errors makes the frontend unusable :slight_smile: let's try it in the backend.

    As for the Purple-Dude handle, me and my colleague wanted to have purple on our company name. That's the Purple bit.
    As we both use the same account in most support forums, this was the first handle we could think of :slight_smile:

  • tlcorbin
    • Able1

    Hah, I gotta luv it! It is a favorite color of mine, I have been an artist longer than I have been at trying to create the perfect website. I would have had to call myself purple-reign-man had I thought of it.

    Good luck problem solving.

    tlcorbin

  • tlcorbin
    • Able1

    Hello, Pali, I missed saying hi when I posted earlier. Patience and I have always been at odds with each other. Had I been born a vulture rather than a human, I would have been packing a machine-gun and lecturing my fellow vultures on the virtues of, "Patience my ass, I am killing something," my vulture motto.

    tlcorbin

  • euDigital
    • Design Lord, Child of Thor

    exactly kimme :slight_smile: last time i jump so soon. Lucky for us, the sites are still in development and we can recreate everything easily in new installs if needed.

    The problem is gone if we deactivate the wpml-marketpress plugin.

  • tlcorbin
    • Able1

    Hello, kimme and Purple-dude, the folks working on the WP-3.5 problems don't seem to be overly concerned or in a hurry to fix the problem. I went to their forum looking for a ray of hope that the problem was being fixed, and was very disappointed.

    You can do the same for your selves. My suggestion, role back to WP-3.4.2 and wait with working features while they get around to fixing things.

    tlcorbin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.