Anybody have MarketPress disappear from site?

This is kind of a question/solution.

Has anyone had MarketPress just disappear from their site?

I have a template site that I created. I have MP, along with a bunch of MP add-ons, including MP Premium Features.

The site is up and functional and I haven’t done anything to it recently (except plugin updates regularly).

Today I had a prospect call me and say that they were getting an error when they tried to access the site. The site was throwing an error saying that my marketpress.php file was missing. When I went into the admin panel, MP was not showing as a plugin (active or inactive). I tried to reinstall MP from the WPMU dashboard and it threw an error saying that MP was already installed.

I checked via FTP and the directory was there.

Very strange.

Anyway — I fixed it by renaming the marketpress directory to ‘marketpress1’ and then installed MP.

Once I did that, the site was back up and running.

Just wanted to note it here in case anyone else had the issue (WPMU staff will know about it) — and also as a solution in case anyone needs to know how to fix it.