Anyone running domain mapping on linode?

I have been trying to get domain mapping done on linode dns panel, does anyone have any experience with this?

  • drmike
    • DEV MAN’s Mascot

    Five minutes with google can't find anything outside of "Oh just add it as an undeveloped domain to the dns manager." That's a big help. Plus two threads on the linode forums where the reply is "What's a parked domain?"

    I'm assuming that these mu installs are in separate accounts. Do you have a dns manager page within those accounts?

    Could just say the heck with it and tell your endusers to cname it to the current subdomain. that's how they do it at edublogs.

  • georgeac
    • WPMU DEV Initiate

    the hosting panel does not have a parking option.

    i am running an nginx php-fastcgi box with the very basic stuff so i dont have a control panel. but linode has a dns manager.

    This is what i have so far.

    The domain mapping plugin works. ie. when i specify the domain in the options for the blog the url redirects to the domain.

    What i am having problem with is telling the dns that the domain points to the root of the WPMU domain.

    I understand that easy way to do it is by setting the A record on the domain side (for example set the A record on godaddy panel). But this is not practical for me due to variety of country level domains.

    I tried creating an A record in the dns of the wpmu domain but since i can only add an ip address as the destination and both the domains are on the same ip address, it does not seem to work. i.e. the a request does not find where on earth the domain is parked.

    When i add a domain it creates its own zone and i see the server default landing page for nginx.

    I understand the next way to do this is by cname. I set up a zone with nameservers and a CNAME only ie no A records or MX records. Set cname in the dns manager thus

    * subdomain.wpmu.com Default

    As i understand it takes all requests and forwards them to subdomain.wpmu.com.

    But it still takes me the default server landing page.

    where am i wrong here. Spent the whole night on google. need help.

    thank you

  • Andrew
    • Champion of Loops

    Hiya,

    I wish we could be more helpful but I'm afraid you're using a service that none of us seem to be familiar with. The best thing to do is ask your host for assistance. Tell them you need to be able to point a domain to your root WPMU directory. They should be able to help you out.

    Thanks,
    Andrew

  • georgeac
    • WPMU DEV Initiate

    i tried, but i am on unmanaged hosting VPS so the help they give is very minimal .

    to put it in a simple manner, using dns,

    how do i add a example.com and redirect all traffic to subdomain.wpmu.com using only cnames or A records?

    any examples would be welcome.

  • georgeac
    • WPMU DEV Initiate

    thank you

    I have created a news zone

    i am using nginx so i did the following in my domain config file

    server {
    	listen  80;
            server_name domain.com *.domain.com;
    
            access_log  /var/log/domain.com ;
            error_log   /var/log/domain.com_error;
            location / {
                root   /var/www/wpmudomain.com;
                index  index.php index.html index.htm;
     if (!-e $request_filename) {
                rewrite ^.+/?(/wp-.*) $1 last;
                rewrite ^.+/?(/.*\.php)$ $1 last;
                rewrite ^(.+)$ /index.php?q=$1 last;
            }
    
            }
    
            error_page   500 502 503 504  /50x.html;
            location = /50x.html {
                root   /usr/local/www/nginx-dist;
            }
    
           # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
            location ~ \.php$ {
                fastcgi_pass   127.0.0.1:9000;
                fastcgi_index  index.php;
                fastcgi_param  SCRIPT_FILENAME /var/www/wpmudomain.com$fastcgi_script_name;
                include        fastcgi_params;
            }
    
            location ~ /\.ht {
                deny  all;
            }
    }

    now the domain redirects to the wpmudomain but everytime i get to the there it is redirected to the new blog signup page.

    any ideas?

  • Andrew
    • Champion of Loops

    now the domain redirects to the wpmudomain but everytime i get to the there it is redirected to the new blog signup page.

    That's how it should behave if the domain mapping isn't setup correctly.

    Could you please provide us with a step-by-step of what you did to install the domain mapping plugin so we can make sure everything is installed correctly?

    Thanks,
    Andrew

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.