Apache modules required by WordPress

Hi,

Wondering if you have any input/experience/referece on wich Apache modules are required by WordPress. We'd like to strip down server modules to decrease load. If it helps, the site's running on a CentOS7.

Thanks!

  • Predrag Dubajic
    • Support

    Hi D.,

    I’m not sure if there’s a definite answer for this as it depends on which functionality you’re looking to have on your site.

    In this article here it suggests only mod_php, cgi or fcgid while suggestions here and here provide some extended list like this:

    mod_alias
    mod_authz_host
    mod_deflate
    mod_dir
    mod_expires
    mod_headers
    mod_mime
    mod_rewrite
    mod_log_config
    mod_autoindex
    mod_negotiation
    mod_setenvif

    Hope this helps.

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.